Need Help dc42


  • administrators

    @saltypetz said in Need Help dc42:

    Error: Bad command: Probe deployment routine for BLTouch
    Error: Bad command: Probe deployment routine for BLTouch
    Error: Z probe already triggered at start of probing move
    Error: G0/G1: insufficient axes homed

    Those messages indicate a problem in your deployprobe.g file. Please post the contents of that file, also the contents of retractprobe.g.



  • I used the ones from the BLTouch post. So I did get somewhere today. It is very hard for the first time.
    But I didn't give up. I love the board.

    ; deployprobe.g
    ;
    Probe deployment routine for BLTouch
    ;
    M280 P3 S10 I1 ; Set servo position to deploy

    ; retractprobe.g
    ;
    ; Probe retraction routine for BLTouch
    ;
    M280 P3 S90 I1



  • Now I am starting to understand I found I post about deployprobe.g retractprobe.g meshing. So now I have it meshing but don't fully understand it yet but it is running trying to mesh now. I have to keep reading more.

    0 %
    × Error: Max open file count exceeded.
    Error: Z probe already triggered at start of probing move
    Error: Max open file count exceeded.
    Error: Z probe already triggered at start of probing move
    Error: Bad command: meshlevel.g
    Error: Bad command: meshlevel.g
    Error: G0/G1: insufficient axes homed



  • @saltypetz said in Need Help dc42:

    Probe deployment routine for BLTouch

    This line is a comment so it should start with ";"


  • administrators

    1. As @denke says. Also I think you are running a file, maybe called meshlevel.g, that has a similar problem (comment line without a ':' character at the start).

    2. Which firmware version are you using? if you are using 2.0RC5 then the "Max open file count exceeded" message may be caused by a known bug in that version.



  • I am running 1.21 should I update it.


  • administrators

    No, stay with 1.21 for now.



  • I found this post and tried this it worked now the bltouch doesn't stop the head it crashes into the bed.
    https://forum.duet3d.com/topic/3724/g30-error-z-probe-already-triggered-at-start-of-probing-solved/4
    I tried what you told lazy_mosquito in this post but it didn't work.

    https://youtu.be/SPIpC9dfDE4

    ; Endstops
    M574 X1 Y1 S0 ; Set active low endstops
    M574 Z1 S2 ; Set endstops controlled by probe
    M557 X0:335 Y45:260 S20 ; Define mesh grid
    M558 P9 X0 Y0 Z1 H9 F100 T500 I1 ; Z probe trigger value, offset in relation to nozzle. And trigger height adjustment
    G31 X-48.8 Y-18.2 Z0 P25 ; Disable the 3th Heater to free up PWM channel 3 on the Duex board.

    ;BLTouch
    M307 H3 A-1 C-1 D-1


  • administrators

    The first thing you need to get working is a basic G30 move without parameters. See https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe. In the case of bltouch, when you send the G30 command the probe should deploy, then it should move towards the bed, and when you push the pin up it should stop.



  • I have been reading and trying everything I can find. I home X & Y send the head to middle of bed. Then send the G30 and this is the only error I get. G30 Error: Z probe already triggered at start of probing move. Red LED on to center of bed as soon as I do the G30 only the blue LED but no movement.

    ; Endstops
    M574 X1 Y1 S0 ; Set active low endstops
    M574 Z1 S1 ; Set endstops controlled by probe
    M557 X0:335 Y45:260 S20 ; Define mesh grid
    M307 H3 A-1 C-1 D-1 ;
    M558 P9 X0 Y0 Z1 H9 F200 T6000
    G31 X-48.8 Y-18.2 Z2.3 P25


  • administrators

    • You should not use parameter I1 in the M558 command for bltouch. That explains the error message you are getting.
    • The XYZ parameters in the M558 command are no longer valid or required, and can be removed.

    HTH David



  • For some reason I have to use heater pin 7 not heater pin 3.


Log in to reply