Problems with Z height upon printing



  • Hello there! I have been away from my printer for a little while due to finals etc.

    I was not happy with how my piezo sensor was working so I decided to change back to a BLTouch. For some reason I can't seem to get the Z height to the right height when the printing starts. I am sure there is something I am missing somewhere.

    My config.g file(are there no code tags?):
    https://pastebin.com/zfsw2Hiu

    Homeall.g:
    https://pastebin.com/vuLVwM6E

    Homez.g:
    https://pastebin.com/GgFJ85Jd

    The Z offset should be 1.30, but it seems like the Z offset is beeing ignored. If I change the Z offset to a higher/lower value the printer still starts printing at Z0.21.

    I am using S3D and have tried several gcodes in the startupscripts to make it work, but I can't seem to make any change at the height at all. At the moment I am only running G28 and G29 S1 in the startup.

    Am I missing something here?


  • administrators

    Check that you don't also have a G31 command in config-override.g.



  • Sorry, I forgot to post that file. I do not have any G31 command in there, only commands regarding the heaters.

    Could there be anything saved to EEPROM?

    Edit: Generating new config files did not seem to make any diffrence either. I recently updated to the latest firmware. Could it be a firmware issue?



  • Tried tdiffrent versions down to 1.20, but none of them made any diffrence. Deleted the /sys/ folder and sat everything up again, yet im still having the same issue. The Z offset is completely ignored, it starts printing from where the BLTouch triggers, and then moves 0.21mm up due to the first layer. Im completely lost here.

    Edit: The Z offset does get applied - When the BLTouch triggers the printer will lift the hotend up 5mm and then adding the Z offset, so it ends up at Z6.3 before printing. However it does not move below the trigger point of the BLTouch.

    Yet another edit:
    By setting the offset to 0 and adding in:
    G92 Z6.3
    G1 F60 Z0

    in the startup script I got it moving to where I want it. I still don't why the offset does not work though. It is supposed to set the current height minus the offset after homing, right?


  • administrators

    I suspect there is an error in your homing files, so please post homez.g and homeall.g. Are you using the bltouch for Z homing, or a separate endstop switch?


Log in to reply