Piezo probe, printer appears unresponsive



  • I'm just beginning to set up the piezo probe which I received some time ago from Simon, so I'm sure that there will be a few questions on the way over the next couple of weeks.

    Do to a number of design considerations I'm currently planning to utilize an underbed piezo setup. Sensitivity at this point looks great, quite a bit better in fact than what I was seeing with the hotend piezo. The first iteration with 27mm piezos was likely too sensitive so I've redesigned the setup around 20mm piezos. I've studied David's post and Simon's as well as the Duet3D Wiki.

    The printer seems not to be responding to trigger signals -- nothing happens when I tap the bed to trigger the blue LED on the PCB during a probe descent. The PCB appears to be reasonably well-tuned for this particular application, and piezo polarities are correct.

    Also, when I use either the bed-leveling icon on the console or run a bed10-6.g macro, after a number of preliminary moves the nozzle begins a probe near the edge at about 7 o'clock but lifts again a few mm before it touches the bed. It then moves to center and back again to the previous position, repeating this cycle until I shut things down (I assume).

    My homed height places the nozzle ~0.1mm above the bed (paper feeler) and I'm using a -0.1mm Z offset as per Simon's instructions. Please let me know which files I might attach so as to determine what I've missed.

    If possible I'd like to be sure that the hotend is lifting in response to a trigger before making changes which will drop the nozzle fully to the bed.

    I'll be sure to do a complete write-up of the details once things are up and running, along with another describing the piezo end stops which are also waiting in the wings.

    Thanks!

    [Edit] Not sure what changed, but one time when running the bed leveling routine from the console icon I did get the nozzle to hit the bed and lift again in the center and a few other points -- again, just one time and I'm not yet able to repeat this. The nozzle is still stopping and rising again without hitting the bed when probing the edge at 7 o'clock as before.

    Also, I'm seeing a string of
    "Error: Z probe already triggered at start of probing move"
    This error appears to be associated with the failure of the one probe point to complete successfully -- but that's just a guess. I've not noticed the blue LED flash at the wrong time during a probe.



  • Much better than trying to explain, here's a video. As can easily be seen things appear to be working except for the probes nearest the camera. I'm also curious, what are all of those slow transverse moves over on the left?

    Piezo probe 03 4k

    Not wishing to get ahead of myself ... but as of now seeing at least some good probes, I'm impressed! This will be my first time having a z-probe. 😋



  • It seems to me that you need to add some recovery time after the printer executed a travel move to the next probing point.
    Play with R parameter of M558 command.
    Please share your config.g file so we can see what the current setup is.



  • Thank you whosrdaddy. I've tried using an R parameter with M558 of a full second, same behavior. I've noticed now that the failed probes begin from a much greater z-height than the others, and the M558 settle pause which I see before the successful probes is missing.

    Also, a setting or command which I've tried has somehow changed the error message, it's now "Error: Z probe was not triggered during probing move". See the relevant portion of the log below.

    I'm attaching the config.g file, not yet fully configured.
    0_1527602996020_config.g.txt

    0_1527602363948_19714da5-04e4-4365-8c86-2e9693609150-image.png



  • Can't determine what brought the change but that error message is no longer appearing.

    Here's a new video with a different bed.g configuration showing things a bit more clearly -- all positions except the one seem to be probing properly. There's an obvious difference -- all successful probes begin from a height of 5mm while that one failed probe position begins at 40mm. It just seems to give up before hitting the bed. Tapping the bed so as to generate a signal during that probe brings no response.


  • administrators

    Are you probing with G32 or with G29? If G32, please post the contents of your bed.g file.



  • I've been using the bed-probe icon on the web interface, would I be correct in assuming that to be G32? I've also tried running various bed.g files as macros.
    These files are from the first and second video respectively.

    0_1527637589779_bed.g.txt
    0_1527637605114__Probe_6fact.txt


  • administrators

    Thanks. the first on has some old stuff in it that is no longer relevant using recent firmware versions. The new one looks OK.

    Which firmware version are you using?

    Please post your config.g file.



  • I'm using 1.20RC4.

    0_1527685193249_config.g.txt
    (Not yet fully configured)



  • Simon solved it, he suggested that I remove deployprobe.g and stowprobe.g from the SD card.
    It's working so beautifully!!

    Thanks to all who replied!

    New video


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.