Strange Moire like texture on prints [SOLVED]



  • Hi.
    This is my first post on these forums.

    I recently got a Duet Ethernet and a Titan Aero for my Prusa I3 style printer, and have been getting a strange artifact on the perimeters of my prints. It looks like some kind of Moire pattern and is very obvious to the naked eye, but difficult to picture. This is not ghosting in my opinion, as it happens on perimeters with no details at all and equally in both X and Y axis.
    0_1527713638427_20180529_203620.jpg

    My belts are all tight and my bearings are ok.
    I'am using x16 microstepping with x256 interpolation on all my motors, and the extruder motor is a 0.9 deg type.
    I'am printing at 50 mm/sec, and slowing down doesn't make any difference. I changed my jerk and acceleration settings to no effect.

    Because I installed both the Duet and the Titan at the same time, I'm really lost as to what is causing the issue.
    Could it be some kind of electromagnetic interference?

    0_1527715352301_20180530_181201.jpg

    This is just a skirt of a print, but you can see the same effect on the lines appearing to have the pattern of the microstepping (top left corner). Sorry for the bad pic, but my camera really doesn't like to take macro pictures.

    Does anyone know what could be causing this?



  • you got the faux carbon fiber look for sure. Whats your driver current set at? looks like the steppers are pissed



  • I have them on a low-ish current setting because I print slow.
    X and Y are 800mA (spec on these is 1700mA, 1.8 degrees).
    Extruder is at 1200mA (spec on this motor is 1400mA, 0.9 deg). None of them get very hot, just warm to touch.
    The thing is, looking at the printer while it's printing you would never imagine anything wrong, as the movement is so smooth and quiet compared to my old Ramps/arduino setup.



  • Can you post your config? Does it happen on long runs or only after turning? Looks like a real bad case of ringing which is often a result of high acceleration and jerk.



  • It happens on long runs as well. That's why I don't believe it to be just normal ghosting.

    Here is the config.g

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun May 13 2018 00:04:59 GMT-0300

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PDuet ; Set machine name
    M551 Pxxxxxx ; Set password
    M552 P192.168.2.15
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S1 ; Enable FTP
    M586 P2 S1 ; Enable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X100 Y100 Z1600 E837 ; Set steps per mm
    M566 X900 Y900 Z12 E300 ; Set maximum instantaneous speed changes (mm/min)
    M203 X9000 Y9000 Z120 E2700 ; Set maximum speeds (mm/sec)
    M201 X1500 Y1500 Z80 E1000 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z1200 E1200 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Disabling the Heater for use with BLTouch
    M307 H7 A-1 C-1 D-1 ; Disables the 7th heater for use with BLTouch

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X190 Y150 Z175 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active low endstops
    M574 Z1 S1 ; Set active high Z endstop

    ; Z-Probe
    M558 P9 X0 Y0 Z1 H5 F120 T6000 ; Set Z probe type to switch and the dive height + speeds
    G31 P25 X6 Y25 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X10:180 Y25:140 S10 ; Define mesh grid
    M376 H10 ; Set bed compensation taper at Z=10mm

    ; Heaters
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T101568 B14795 C5.136692e-7 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S130 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S1 I0 F500 H1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S20 R22 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    ; Miscellaneous
    M912 P0 S5 ; Sets the MCU temperature offset
    M501 ; Load saved parameters from non-volatile memory
    T0 ; Select first tool



  • looks extruder related since the pattern has no consistency. is that over extrusion by your thumb?



  • @3dpmicro Yes. I've since reduced my extrusion to 0.98 and lower the temperatures a bit. The overall "moire like" pattern didn't change though.



  • thats not much. try .8 or more until it clearly under extrudes. you calibrated the extruder I assume? what extruder is it?
    grabbing for straws.....can you back off idler and pull filament in and out easily?



  • The extruder is a Titan Aero.
    Yes, I've calibrated it, and yes, the filament goes smoothly in and out when I release the idler.
    I've just tried a different more powerfull motor on the extruder and still the same.

    I'll do the under extruding test next...



  • I don't necessarily have an answer for you but can you clarify the following?

    Material, print temp, nozzle diameter, track width, and print speed? Particularly in reference to your single layer print. Come to think of it as that is first layer it is probably very slow? If so print speed probably not a contributing factor as the effect is also visible further up your print where the speed will be a good proportion faster.

    Judging by your overall print quality your further along the battle than me! The calibration guide reference by the RepRap wiki talks about calibrating the extrudion temp by dropping the temp until the track appears dotty then increasing it by 10C. Perhaps you are knocking on the low limit of extrusion temp?

    I think the bed compensation related artefacts are more regular but maybe worth testing with no bed compensation.

    Edit: Sorry, you've already said 50mm/s and slower didn't help.



  • @rbjam83 Try a 1.8 deg stepper on your extruder, there is really no advantage to 0.9 here...whereas there arguably would be on X&Y.

    Try a different micro step / interpolation setting on E also.



  • trying to think how you can isolate the problem. Raise the nozzle 100mm or so and extrude filament in to air at different speeds and see what that looks like, if its smooth and consistent. I would switch to a single wall cube or cylinder and continue making changes. I think this will make it easier to see the effect (or no effect) of a change



  • @doctrucker I'm printing PLA, with a 0.4mm nozzle, 0.45mm track width, 190ºC temp, 0.2 layer height.
    I have tried temperatures between 170ºC and 200ºC with no difference.

    Also, I got pretty excited about disabling mesh bed compensation, but it did nothing...



  • @3dpmicro I've tried under extruding till I saw holes on top layers (at 0.89 extrusion) and again, no difference on the perimeters.



  • @benkay Yes, I did that. Swapped my 0.9 deg for a 1.8 and still the same. Also disabled interpolation on the stepper drivers, no difference.



  • @3dpmicro I printed a vase in spiral mode and I don't see much improvement to be honest, here are some pics:
    0_1527814316542_20180531_205708.jpg
    0_1527814371961_20180531_211813.jpg



  • Did you try extruding into air to see if what is coming out of the nozzle is smooth and consistent. I might even try tripping the z home switch with the nozzle 100+ mm above the bead then running a program and just see what the material looks like coming out. If its smooth amd consistent then we can be fairly confident it's in the x or y. If that looks good print a cube in vase mode (no top) to see if it's x, y or both. Need process of elimination



  • Watching this thread with interest.

    Have you tried emailing E3D direct to see if they are aware of any possible causes?



  • @3dpmicro Just did the extrusion test, and is was super smooth. So I guess I can check the extruder off the list then.

    I just tried a different set of pulleys, both 20 and 16 tooth on X and Y, and again no difference.
    I already did a print in vase mode, it's showing equally in x and y. So equally in fact that I'm thinking the stepper drivers just don't "like" my axis motors for some reason.
    This is my first time on TMC drivers. Is there any thing else to configure in them besides microstepping and interpolation? I've got a feeling I'm missing something...



  • @doctrucker I'm starting to think this is some combination of stepper motor/driver setting issue.
    The Titan seems to be fine.


Log in to reply