DWC 1.21.1, dual Y axis and 4th rotary axis



  • I'm trying to add 4th axis to a WorkBee with dual Y axis. Right now the axis definition looks like:

    M584 X0 Y1:3 Z2 U9 E4:5:6 P3

    and I'm trying to change it to:

    M584 X0 Y1:3 Z2 U9 A4 E5:6 P3

    All I get is the following error message:

    JavaScript Error

    A JavaScript error has occurred so the web interface has closed the connection to your board. It is recommended to reload the web interface now. If this happens again, please contact the author and share this error message:

    Version: 1.21.1
    Message: TypeError: status.coords.xyz[axisNames.indexOf(...)] is undefined
    URL: http://192.168.1.200/js/dwc.js
    Line: 873:75
    Error object: {}

    and DWC keeps disconnecting.

    The U axis is used for squaring the machine when homing.



  • 2 things, have you tried clearing your browser cache, and have you tried , removing the sd card, modify the config.g file on a PC and then re-booting with the modified code ?



  • All tried! The only way to make it work again was to get the SD card into the PC and restore the config.g file from backup. I have even tried with different browsers, never used before on the Duet.



  • "Additional axes must be created in the order UVWABC"

    https://reprap.org/wiki/G-code

    I think A4 should be V4.



  • @jmjcoke Duet3D GCode wiki specifies for M584 "In 1.20 and later firmware you can create new axes in any order. In earlier firmware versions, additional axes must be created in the order UVWABC." I'm using latest 2.0 beta firmware and I need a rotary axis. U, V and W are linear axis, not rotary ones, so they are not really suitable.

    Also, not document specifies that the drivers mapping really needs to have a specific order. But I have clearly seen that some combinations do no work. In the end, the really annoying thing is that there is no way, apparently, to have a dummy linear axis used only while squaring the gantry and a rotary one to always be used!


  • administrators

    It appears that DWC doesn't yet support allocating axis names in random order, even though RepRapFirmware does now.


  • administrators

    @catalin_ro said in DWC 1.21.1, dual Y axis and 4th rotary axis:

    M584 X0 Y1:3 Z2 U9 A4 E5:6 P3

    There is currently an issue in DWC with the 'A' axis being configured but hidden, so I suggest you remove the 'P' parameter for the moment or change the 'A' axis to something else. I'll commit a fix when I have some more DWC enhancements working.



  • @chrishamm That means that if I chose B instead of A it should be OK? My 4th rotary is parallel to the Y axis anyway, so B is correct!


  • administrators

    @catalin_ro yes that ought to work. The current bug in DWC only occurs if you configure the A axis but hide it via the 'P' parameter. Alternatively you could stick with 'A' but remove the 'P' parameter.


Log in to reply