Printing without a heater (syringe clay printer)



  • Re: No heater printing

    Hello, I have built a clay printer which does not require any heating. I am new to RepRap Firmware, having previously used Repetier. I like RepRap firmware so much better already. I have been able to print without heaters by sending the M301 P1 command to enable cold printing. However, I would prefer to set up the machine as a "permanent" cold printer. I listed the number of heaters on my tool as 0, but i still get the temp warning until I send the M301 command. One aspect I liked about Repetier was the option in their firmware configurator to set the temperature sensor to "fake temperature sensor, always returning 25c". Would it be possible when configuring a syringe based paste printer to setup the firmware to omit all the temperature related settings?



  • @tom_lauerman I'm using a Duet Wifi and i have the 1.21 Firmware and interface.



  • @tom_lauerman

    I'd have thought putting M301 P1 at the end your config.g ought to work.


  • administrators

    This should work already, we have at least one other user controlling a clay printer with a Duet. Which firmware version are you using? Please post the contents of your config.g file.

    One known bug is that the layer count displayed in Duet Web Control doesn't increment when there are no tool heaters. This is fixed in the 2.0RC6 firmware.



  • @dc42 Thanks for your reply! I'm running firmware version 1.21. Here are the contents of my config.g file:

    ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Jun 01 2018 14:49:13 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare

    ; Network
    M550 PBricoleur ; Set machine name
    M552 S1 ; Enable network
    M587 S"attwifi" P"" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M350 X16 Y16 Z16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z4000 E5000:370 ; Set steps per mm
    M566 X900 Y900 Z12 E120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200:1200 ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250 E250:250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E2000:800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X480 Y317 Z750 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:465 Y15:302 S20 ; Define mesh grid

    ; Heaters
    M140 H-1 ; Disable heated bed

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0:1 H ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M568 P0 S1 ; Enable mixing for tool 0
    M567 P0 E0.5:0.5 ; Set mixing ratios for tool 0

    ; Custom settings are not configured


  • administrators

    @tom_lauerman said in Printing without a heater (syringe clay printer):

    M563 P0 D0:1 H ; Define tool 0

    Remove the letter H from that command, because it is being treated as if it says H0.



  • Fantastic! That did the trick. The extrude and retract buttons are grayed out in the web control but they still extrude or retract when clicked on. I understand from previous posts that this has been addressed in the RC versions. Would you recommend switching from 1.21 to the latest release candidate? I'm the only user of this machine - its a one-off for research purposes, not something designed for production and sale.


  • administrators

    I released firmware 2.0 yesterday, so I suggest you try that.



  • @dc42 Wow! I'll do that right now, thanks!


Log in to reply