M350: Set microstepping mode



  • Hi

    What do you set the M350 parameters to if you use external drivers with there own micro-stepping?

    Thanks


  • administrators

    Either don't use M350 at all, or if you need to use it for the internal drivers, don't mention any axes that use external drivers in the M350 command.



  • Just can not get the motors to move.

    See latest setup below. I am using DM542 Full Digital Stepper Drives, they require a pulse width of 2.5 2.5 us. Drive are set to 1600 micro steps.

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P5 R1 T2.5:2.5:5:0
    M569 P6 R1 T2.5:2.5:5:0
    M569 P7 R1 T2.5:2.5:5:0
    M569 P8 R1 T2.5:2.5:5:0
    M584 X5 Y6 Z7 E8 ; Apply custom drive mapping
    M92 X34.6538 Y31.9881 Z79.97029 E209.21 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250 E250 ; Set accelerations (mm/s^2)
    M906 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    Please advise


  • administrators

    First check whether the Enable signal is working properly. When you power up the Duet, the motors should be un-powered and therefore free to move. When you try to home them, or to jog them (with M564 H0 in config.g or sent first to allow movement before homing), they should be powered up and no longer be free to move. If you find they are locked to start with and become free when you try to move them, then change R1 to R0 in your M569 commands for the external drivers.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.