Getting the part cooling fan to control



  • Hi

    just setting up my printer. I am doing a 20mmtest cube and expected no fan for layer 1, but my part fan is spinning.

    Is this setting right? I guess not but….

    "M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on"



  • Usually P1 is the hot end fan and P0 is the part cooling fan so ideally we need to see what you have set for P0. However, the part fan would usually be controlled by gcodes generated by the slicer but they aren't very good at starting with the fan set to off. So usually, one would configure the fan in config.g to be off (i.e. M106 P0 S0.0…...) then rely on the slicer to turn it on after the first layer by putting an M106 Snnn into the gode file for the object being printed. HTH


  • administrators

    As you are remapping the default print cooling fan to fan 1 as we discussed in the other thread, you need to disable thermostatic mode on fan 1 using M106 P1 H-1 S0.



  • @deckingman, thanks a short in the mini-circuit board in the head of my wanhao d6 blew the P0 channel for me so I had to remap it to P1.

    @dc42, thanks

    Otherwise it was a perfect print, and so quiet!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.