Web Based Configuration Tool



  • Just starting to commission my new printer so I tried this out.

    Very impressive - answering questions makes life so much easier than trawling through all the various g codes. Many thanks to Chris Ham.

    Just a couple of things I noticed. I have a mixing hot end ( 3extruders, single heater). So, I defined 4 tools all using all 3 extruders and the single heater but with different mixing ratios for each one. i.e Tool 0 is set to mix at 1:0;0., tool 1 is 0:1:0, tool 2 is 0:0:1 and tool 3 is 0.33:0.33:0.34. This is all fine and dandy but the generated config.g may be messed up as far as heaters are concerned. What I got was H1 for tool 1, but just H with no number for the other tools. I was expecting to see H1 for all tools. I'm not sure what "H" with no number would default to, so that's why I said the heaters may be messed up, not that they were messed up.

    The only other thing I can think of would be adding support for the PT100 and Thermocouple boards (M305). There is the facility to add "extras" at the end of the process so it's no big deal to add these but the user needs then to comment out the thermistor and ADC parameters presumably (hope so 'cos that what I've done).

    Ian


  • administrators

    Hi Ian

    H with no number looks like a bug, I will pass on to Christian. You are right they should be the same heater for each.

    I will add the feature request to chris about the PT100/TC boards.

    Regarding the way you defined the tools, I presume you have added the tools with no feedrate for 2 out of 3 of the colours to overcome the extraction issue you referred to in another conversation?

    For those who find this thread and are interested how to use the Diamond hotend:

    I assume you defined the tools using M563 and then set the mixing rations using:
    http://reprap.org/wiki/G-code#M567:_Set_tool_mix_ratios

    After that you will then be able to import a multipart model into your slicer and define each part as using a different tool to get a different colour/material for that part.


  • administrators

    The PT100 and thermocouple support is already there, it's under "sensor channel" on the Heaters page.



  • @dc42:

    The PT100 and thermocouple support is already there, it's under "sensor channel" on the Heaters page.

    Hi David,

    I was going to say that although one can change the ADC channel, it doesn't give Xnnn but forget that. I've just double checked and sure enough it is there but right at the end of the ADC parameters

    i.e. M305 P0 T1000 B3988 C0 R4700 L0 H0 X200.

    God that was hard to spot. Presumably the firmware will ignore other values that are in that string?

    Ian



  • @T3P3Tony:

    Hi Ian

    Regarding the way you defined the tools, I presume you have added the tools with no feedrate for 2 out of 3 of the colours to overcome the extraction issue you referred to in another conversation?

    For those who find this thread and are interested how to use the Diamond hotend:

    I assume you defined the tools using M563 and then set the mixing rations using:
    http://reprap.org/wiki/G-code#M567:_Set_tool_mix_ratios

    After that you will then be able to import a multipart model into your slicer and define each part as using a different tool to get a different colour/material for that part.

    Hi Tony,

    Yes that's correct. This is how I use the Diamond hot end currently on my ageing, creaking Mendel. By defining a mix ratio of 1:0:0 one is effectively using only one extruder. So, for the three inputs, all the tool definitions are the same in that they all have the same 3 extruders and they all share the same heater and they are all set to use mixing. What distinguishes them apart is the mixing ratio. So tool 0 has a mix ratio of 1:0:0 meaning that it will effectively only use extruder 0. Tool 1 has the mix ratio set to 0:1:0 so effectively only uses extruder 1. Tool 3 is set to 0:0:1 so will only use extruder 2. Tool 4 has a mix ratio of 0:34:0.33:0.33 so uses all 3 extruders in (almost) equal amounts.

    That's the way I have it set up. I have 3 tools which are each of the 3 single filaments and one which is a mix of (by default) all 3 in equal proportions. There is nothing to stop anyone from defining any number of tools e.g, 0.5:0.5:0 which would effectively give 50% of each of 2 filaments and 0 of the third. The only thing to remember is that the sum of the mix ratios must add up to 1. I'm not sure what would happen if it didn't - presumably under or over extrusion.

    Having a huge number of tools isn't really necessary because one can change the mix ratio on the fly or have it embedded in the GCode. I don't know if you saw this http://forums.reprap.org/read.php?166,647072

    Ian

    P.S. Duet is wired up and running - commissioning is going well so far.


  • administrators

    Ian, is there any chance you didn't activate the H0 heater for all tools on the config tool? You could check that again by loading "config.json" after clicking on "Use existing template" on the welcome page.

    At the moment the config tool tries to map only one heater+extruder per added tool, so assuming you have four heaters+extruders and create three new tools, the default tool mapping would look like this:

    T0: H0, E0
    T1: H1, E1
    T2: H2, E2
    T3: H3, E3

    Maybe it would make more sense to pre-select all the heaters and extruders if a tool is added and the number of extruders and heaters differs? I guess that would make things a bit simpler when mixing nozzles are configured.

    In addition it could show a warning if a tool is supposed to be generated without assigned extruders or heaters.



  • Just another quicky. The generated homing files don't have a movement to home at the end. Obviously that's irrelevant for home X and home Y but home Z and home all left the probe at the trigger height and at the X Y probing position. Is that expected behaviour? I don't have anything to go on other than the original RRP Mendel files which always moved Z to 0 after homing and home all moved all 3 axes to 0. Looking at a Slic3r generated gcode file, there doesn't seem to be anything at the start to move the axes to 0 if it isn't done by the homing files.


  • administrators

    Well, it depends on what you prefer - I like to leave the nozzle at the trigger height when the bed is probed.

    As a consequence all my G-code files have a custom starting G-code which instructs the printer to go just beyond the bed and then to go down to Z=0.3, which allows me the do a trivial "snort-cutter" move that removes left-over plastic from the nozzle just before anything is printed. Also if you have a sensitive build surface like BuildTak and leave the nozzle at Z=0, there is a risk of damaging it when the nozzle is heated up.

    If you find this behaviour disturbing, I may add an extra option to the config tool to move the nozzle back to XYZ=0 once Z has been homed/probed, but I guess that's really optional.



  • I noticed this configuration tool mentions the ability to define a Steinhart-Hart coefficient as term C of the M306 gcode in Firmware 1.16.

    Is this supported in the current version 1.15c or do we need to wait for 1.16?

    Also, upon entering the appropriate values from the Semitec 104-2GT datasheet I get:
    M305 P1 T100000 B4338 C7.034421808033219e-8 R4700 L0 H0

    Is scientific notation OK or should that be 0.0000000703442181?



  • AussiePhil, that is a bit off-topic, but could you explain a bit (preferably in another thread) how you did cool your board, as the value of 1600 is indeed quite high for the Duet 0.8.5. Your machine is quite on the edge, it might be interesting to create a page with some specifications on the RepRap Wiki.

    As for the value exceeding limits in the configuration tool, instead of enforcing values, may be a warning might be better or the possibility to overpass the told limit.



  • @chrishamm:

    Ian, is there any chance you didn't activate the H0 heater for all tools on the config tool? You could check that again by loading "config.json" after clicking on "Use existing template" on the welcome page.

    At the moment the config tool tries to map only one heater+extruder per added tool, so assuming you have four heaters+extruders and create three new tools, the default tool mapping would look like this:

    T0: H0, E0
    T1: H1, E1
    T2: H2, E2
    T3: H3, E3

    Maybe it would make more sense to pre-select all the heaters and extruders if a tool is added and the number of extruders and heaters differs? I guess that would make things a bit simpler when mixing nozzles are configured.

    In addition it could show a warning if a tool is supposed to be generated without assigned extruders or heaters.

    Hi Chris,

    You are absolutely right - I didn't activate the heater (E0 in this case) for all the tools - my bad. In my defence the configurator did show the heater as being E0 and I assumed that it was selected, but on closer examination I can see that it was in a lighter shade of grey than when it is selected. Maybe a larger contrast between selected and not selected might help in these situation? (esspecially for old guys like me who's eyesite isn't what it was).

    So I can confirm that it does work as it should. Your other suggestions sound good.

    Ian



  • I Would also suggest altering the Bed.G generator to fit in with the latest FW that will allow for upto 64 probe point's and also to allow for a Probe offset in there that does not impact the Config.G file.

    I ran it thru a short while ago and it didn't actually complete Ie it didn't download anything?

    Maybe change the selected colour to Green that would show a little better?

    Doug



  • @chrishamm:

    Well, it depends on what you prefer - I like to leave the nozzle at the trigger height when the bed is probed.

    As a consequence all my G-code files have a custom starting G-code which instructs the printer to go just beyond the bed and then to go down to Z=0.3, which allows me the do a trivial "snort-cutter" move that removes left-over plastic from the nozzle just before anything is printed. Also if you have a sensitive build surface like BuildTak and leave the nozzle at Z=0, there is a risk of damaging it when the nozzle is heated up.

    If you find this behaviour disturbing, I may add an extra option to the config tool to move the nozzle back to XYZ=0 once Z has been homed/probed, but I guess that's really optional.

    Hi again Chris,

    I have no personal preference as to how it should be and it's certainly not disturbing behaviour. My own way of doing it is to pe-heat the nozzle to around 120deg C before homing Z as the Diamond hot end has a tendency to ooze after a print has finished. On homing prior to the next print, the resulting lump of cold plastic used to flex the bed on my somewhat flimsy Mendel, and really screw things up. I guess everyone has their own way of doing it. I'm just thinking of new users who maybe haven't got around to doing any sort of start gcode on their slicers. They will (should) at least home all before starting their first print, so having it go to XYZ =0 might be a better default than leaving it somewhere else?

    Ian



  • Ian Bare in mind that on a delta you home to Max Z tho I would think that it takes this into account (At least I hope so)

    Doug



  • @Dougal1957:

    Ian Bare in mind that on a delta you home to Max Z tho I would think that it takes this into account (At least I hope so)

    Doug

    Hi Doug,

    Yes the configurator does that. You can tell it whether home is max or min for any of the axes.

    Ian



  • I have found a wee bug, genuine this time and not just me. When configuring tools sharing the same heater (mixing hot end), the code for setting the mixing ratios should be M567 and for turning on mixing is M568. The configuration tool generates a config.g which has M569 (instead of M567) for setting the mixing ratios (but the M568 is correct). I just tried the tool again, being extra careful that I asked for all the right things and got the same result.

    Hope you don't mind me pointing that out.


  • administrators

    Thanks Ian, I've just fixed the config.g template. Now it should generate the right M567 code when a mixing tool is defined.



  • Bump in case my question above got overlooked…



  • Just had a quick go with this, one thin I noticed was in the homeall.g file the z homing appears to be done at the corner (first point) rather than the middle.



  • @DebugBear:

    Just had a quick go with this, one thin I noticed was in the homeall.g file the z homing appears to be done at the corner (first point) rather than the middle.

    Under "Endstops", then "Z Probe", there are settings for Probe X offset and Probe Y offset. Put the values you want in here and it'll generate the x and y moves in the homeall.g and home Z files (at least I think it does).


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.