G32 sends crashes the bed agains the nozzle badly.



  • Hello,

    I tried to use G32 command and it starts by homing all axis correctly as I configured at the homex.g files. The it deploys the probe and simply crashes badly the bed against the head (even broking my X carriage......) Then, with the Z motors still stuttering with force it moves the broken head to the first probing point configured at bed.g file....

    Please, what I am doing wrong?

    bed.g contents:

    M561 ; clear any bed transform
    G28 ; home all axes
    M98 Pdeployprobe.g ; deploy mechanical Z probe
    ; Probe the bed at 4 points
    G30 P0 X50 Y20 H0 Z-99999
    G30 P1 X50 Y260 H0 Z-99999
    G30 P2 X250 Y260 H0 Z-99999
    G30 P3 X250 Y20 H0 Z-99999 S
    M98 Pretractprobe.g ; retract mechanical Z probe



  • What kind of printer? What kind of probe?

    Does triggering the probe with your finger (or similar) show up in the web interface?



  • Thank you Danal,

    It is a CoreXY machine (Hypercube Evolution) and uses a servo+optical endstop probe (https://www.thingiverse.com/thing:2890290).

    Manually trigerring of the probe works fine - also during home Z or home all as the probe is my Z_min endstop.



  • Problem solved!!!

    Added some time after the deployment of the probe at the deployprobe.g macro:

    G4 P300 ; Wait 0.3 sec.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.