Strange series of failures



  • I had noticed over the last week or so how my hotend temperature reading was behaving a bit strangely. It would seem to get stuck on a temperature and then after a few seconds suddenly update to the actual temperature. Today, when I was about to start a print, it reached the desired temperature. After a while, I started to smell something unfamiliar. The temperature read as ~230, which is what I want for my PETG, so I didn't think much of it. Seconds later, smoke came out of the hotend area! 😱 I immediately cut the power and restarted the Duet without turning on ATX power. The temperature now read 300+ °C!

    Once everything had cooled down, I checked the wiring of the thermistor, which seemed fine. I couldn't get it to fluctuate by wiggling the cables or anything. But I noticed the hotend fan was still turned on even though the temperature was very low, which it shouldn't, considering I have it set to be thermostatic. I now cautiously tried turning on the heater again, but the temperature never increased and RRF faulted. I assumed it was the thermistor acting up again, but to my surprise, the heater block was still cold!

    I now tried turning off the fan (first turning off its thermostatic mode), but it doesn't react at all – it's always at 100% even though the firmware claims it's off. When I touch Duet's CPU, it's so hot I can't keep my finger on it. It's not supposed to be like that, right?

    So what on earth might have happened?! A thermistor, a heater and a fan channel all failed at once? I didn't mess around with the electronics or anything; it was just a normal print. Is it time for a new Duet board? 😞


  • administrators

    @tomasf ouch!

    My immediate thought is that the heater cartridge has failed and fed 12V/24V back into the thermistor... can you check continuity between the heater cartridge wires, the heater bock. and also between the heater block and the thermistor wires? Another possibility is a short within a wiring loom ( this has happened to at least one person who reported on the forums before) where the VIN voltage made it to either a fan or a thermistor).



  • @t3p3tony Thanks for the tips, Tony.

    My heater block is anodised, so it's somewhat difficult to check continuity. I scraped the surface to reveal some of the aluminium underneath, but it seems there's no continuity between it and heater or thermistor wires.

    I don't think it's a wiring loom issue. I use Cat5 cables from the Duet to the Smart Effector. The ends look fine, and it seems unlikely the wires would somehow short inside the cable.

    I disconnected the heater wires completely and checked the voltage on the heater output. It seems to fluctuate in the hundereds of millivolts, regardless of whether heating is on or off. The E1 heater does seem to work, though. If I redefine my tool to use H2, I get a solid 24 V on the E1 heater output.

    Perhaps there is hope for this board. I only use a single extruder anyway, so I can use the spare heater channel and another fan output. I've ordered a new heater+thermistor part and a new heater block, so hopefully I can get back up to speed soon.

    It would still be nice to understand why this frightening situation happened so I can avoid it in the future. It'd be sad to replace the heater and thermistor and use spare outputs, only to have the same thing happen again.


  • administrators

    @tomasf yes it would be good to get to the bottom of it. It looks like something caused the Duet to freeze as well as frying a heater and fan circuit. That's why I thought it could be a wiring loom/heater/thermistor/fan issue.

    I have a feeling that it was cat5 cable in a loom that developed the fault for someone else.


  • administrators

    @tomasf it was @DjDemonD using network cable that had a short inside a wiring loom:

    https://forum.duet3d.com/topic/5509/might-have-finally-killed-a-duetwifi/14



  • Yes I would say despite their initial apparent usefulness, network cables are designed to be routed, installed and then remain basically motionless for the rest of their working lives. Not to be accelerated about by a 3D printer over many hundreds of hours. As such the insulation wears through and then you've got a problem.

    I think it also doesn't help that some cables are made by pulling the cores through the outer insulation, others by moulding the insulation around the cores, I suspect the latter is slightly more suitable, but probably not much more.

    To those using network cabling already, I'd say consider running normal cable for your hotend heater alongside it, and leaving the cat5/6 handling just fans/sensors etc.. far less potential for a really nasty short circuit, which is extra problematic if you have 5v fans, as the 5v buck converter IC fails then the 3.3V reg, killing all the IC's at once.


  • administrators

    @djdemond the fans can also be carrying 24V so probably limit to only sensor wires... But overall it's not ideal.

    Enforcing minimum bend radius also helps.



  • Thanks for the insight. I have replaced the cable with a different type and replaced the heater+thermistor. The new heater, connected to the E2 heater output, now heats. The hotend fan, connected to FAN2, also works.

    Unfortunately, the bed heater seems dead, too. This makes me think that it might not be the wiring of the effector that caused this whole mess. But who knows.

    Unfortunately #2, I can't get any thermistor channel to work either. The temperature hovers around 30-31 degrees, varying slightly, which makes it look reasonable, but it never changes when the actual temperature rises, and the firmware faults after a few seconds. It even stays the same temperature even if I completely disconnect the thermistor wires! (Perhaps the bed thermistor does still work, but I can't tell since the bed never heats up anyway.)

    So I think this Duet is pretty useless, and I need to buy a new one. Thanks for all your help!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.