Odd Z 2.50mm offset after homing, and Z homing generally



  • Hello,

    I have been setting up my corexy system (moving from Smoothie), and got it to behave quite nicely, BUT!

    1. The web interface shows Z-position as 2.50mm after homing, not zero. Cannot really see where that comes from?

    2. The Z-homing generally, both X an Y home beautifully in two passes, first a fast one, then back off and repeat slowly. But the most important homing, the Z, is done with just one pass and is quite inaccurate unless I set the homing speed to excruciatingly slow speed, which is unacceptable on a large volume corexy.



  • Disregard!

    Stupid me. I found the separate homing macros made by the configurator. Well, the configurator did make them odd...



  • If you're using a z probe you can make adjustments to the M558 F parameter in macro, so you can probe once with a faster feed rate to get the bed up quicker and then again more slowly for better accuracy.

    The configurator gives a pretty good running start, but it really pays to go through it line by line and read the gcode wiki to get a grip on what it's actually doing. It can also be easy to pick the wrong check box in the configurator and get really unexpected results. It also occasionally has bugs and oddities.



  • Yep, Was easily adjustable like I want it in the homing macros. The web configurator is clearly geared towards using a probe, and the results for normal Z-endstop are borderline useless.



  • @sikasid

    I use a z=0 switch and used the configurator for initial set-up. When you select the switch option in the configurator it shows two offsets of 2.5 mm and a threshold value of 600 without any explanation of what they are. I left the defaults set as is, which puts them in the config.g file.

    The first time I ran some gcode on the machine as a motion test, it slammed the bed into the extruder nozzle and dragged the nozzle about 100 mm before I managed to hit the emergency stop. At least one of those 2.5 mm offsets are best explained as "how deep a gouge would you like to put in your PEI print surface?"

    Setting the offsets to zero (and replacing the PEI on the bed) fixes that problem. I still don't know what "threshold" is for in the context of a z=0 switch.


  • administrators

    The configurator needs to be changed so that if you select a Z min endstop switch, it asks you for the Z height at which the endstop triggers, and puts that value in the G92 commands after the Z homing moves in homez.g and homeall.g. We'll get this done.



  • Hi I had this problem time back (old site) so I cann't find the answers so hear I am again with ths same problem.
    Keep in mind I have not made any changes that I know of that cause this offset.
    Everything was working fine but today after having done some work on the frame when i did homing my Z probe would fire at a greater distance from the bed so I did a setup. When I tested it I was at 2.709 and in the interface I had 2.71, M114 would give me 2.079 (put tjis in the config.g). After start again and doing homing It still stops much farther from the bed,
    I have no bed compensatio,n no Z offsets and use a M561 at the end of config. There must be something else I'm missing but cann't find.


  • administrators



  • Thamks will give it a look, didn't see this new section. To much work to have time for the hobby.



  • Yeah gave it look it's more or less a copy of your other page https://miscsolutions.wordpress.com/mini-height-sensor-board/
    And thats what I did , so I will try again for the third time.

    Ok only difference is in my config.g I have no G1 but as for the setup rest
    is the same.

    Update did the setupagain using G31 Z0 instaed of older G31 P500 Z1.0.

    any way first try of G30 S-1 gave me 2.59 second third fourth G30 S-1gives me 7.08 / 7.09 and Z stops at that height...have a G1 Z5 F6000 S2 in homez.g so that correct then. will set it to zero and see what happens.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.