Stringing: Retraction and Travel speed



  • Hi all,

    I'm having issues with stringing that I don't seem to be able to remove. I'm using firmware retraction and simplify3d with 'Include M101/M102/M103 commands' enabled (G-Code tab) and retraction etc disabled (Extruder tab).

    Printer: i3 clone with Duet Wifi and Titan Aero extruder

    I've set retraction up as follows and set pressure advance off for now.

    M572 D0 S0
    M207 S1.2 R0 F2400 T1200

    I've also got the non print travel speed set to 200mm/s.

    To the naked eye it looks like the retraction isn't starting before the travel starts so no matter what I do I can't get rid of stringing.

    What is the order of events for retraction (I've seen it somewhere but can't find it now that I want to know!) ?
    Should I be lowering my travel speed to ensure the filament is fully retracted before the print head has travelled too far?


  • administrators

    @drammy the retraction should complete before the travel move starts AFAIK (@dc42?)

    Possibly try adding a Z hop in M207 temporarily to see the effect more clearly.



  • @t3p3tony Thanks for replying Tony. Could it be something to do with Simplify3D using M101, M102, M103 instead of G10 and G11?

    I've played with all sorts of increments of S, R, F and T as well as Z. I've z hop but it doesn't make any difference.

    I get your point though so will add z hop in to see if it allows me to see the movements more clearly..



  • I would say that you may be retracting too much and slowly for the Aero. Anything over 1mm really risks jamming with the aero on long prints due to filament swell.

    Here's what I use for the Aero and get no stringing at all with a 0.4 nozzle.

    M572 D0 S0.05
    M207 S0.8 R0 F7200 T1200 Z0.0

    Acceleration M201 E8000 and jerk M566 E1600 for the extruder which is an E3D "compact but powerful" 0.9 motor.


  • administrators

    @drammy I have nout used S3d for a long time, and then not for firmware retraction. M101 etc should be replaced with G10 etc or else the retraction won't happen at all.



  • @t3p3tony I can see the retractions happening.

    I followed @dc42 instructions on a reprap forum post.

    @dc42 it was an old post - is this still correct?



  • @phaedrux yeah I've seen you post your retraction settings a few times and have tried them already.

    Will try again though and look at the other config settings as you suggest, thanks.

    I'm also using the 0.9 compact but powerful.



  • What material are you printing? Does it happen with everything or just certain ones?



  • @phaedrux I've spent quite some time improving the print quality and this is my last thing on the list now.

    So I haven't tried other materials yet. I just went with what I had in which is a wood fill pla. Maybe not the best material to tune retraction with tbh.

    I read on the e3d forums not to go above 2mm retraction else risk jams. So I now have jam at 1.2!

    Just as you said. Wish I'd asked on here before I'd started...

    Any techniques for clearing a clog from the titan aero? Can't push filament in and the filament has sheared so no longer connected to the jammed bit..



  • Oooooh... Wood fill is probably the worst material possible to do tuning with. It's really stringy and it can carbonized and clog really easily.

    You may be able to clear the clog with an atomic pull but it's going to depend how burnt up it gets in the nozzle and if you can actually push some new filament down into the melt zone.

    Clearing jams from the aero are a pain because it can be laborious to take apart and put back together.

    If possible try the atomic pull with other filament. Wood fill tends to break easily I find.

    If you can't get it clear you might have to disassemble and use a tiny nozzle drill bit to try and push it clear. Ive had to do that once and ended up having to keep the hotend hot while clamped in a vise so it was soft enough to push through.

    Good luck.



  • @phaedrux Oh well, you live and learn! I prefer to not ask questions until I've tried things but in this instance it would have paid to ask first!

    Thanks for the suggestions. I have some accupuncture needles and a 1.6mm rod that came with the printer for clearing jams but it ain't budging. I don't want to put to much pressure on the print head whilst it's assembled in case I'm forcing something other than the filament.

    Guess I'll be taking the quite fiddly aero apart then..

    How much do I need to disassemble?



  • How much you disassemble will depend on how it's mounted. For me that basically means taken the whole carriage apart.

    https://e3d-online.dozuki.com/Guide/Titan+Aero+Assembly/23?lang=en

    You can probably get the nozzle itself off from the heat block without taking anything apart. Will probably have to warm it up first. That might let you use your needle and at least see what if anything is stuck in the throat.

    If the blockage is contained to the nozzle you can probably get it clear with just some tools and heat.



  • Good news.. the blockage was just off the hobbed gear. I think I had the tension too high so with all the fast retractions the gear was chewing through the filament and ultimately jammed the top of the inner PTFE lining.

    I'll get the rest of the extruder put back together this evening and re-test with your settings @Phaedrux. My extruder jerk / acceleration was quite low compared to your settings so that might explain the slow retracts to the point where the travel was starting before the retraction?

    @dc42 - I followed your forum post here and am using S3D to send M101, M102 and M103 codes for retraction - is that still valid? Could that explain why I'm seeing travel completing before retractions?


  • administrators

    @drammy, using S3D M101/2/3 commands to control firmware retraction doesn't work quite right because S3D doesn't generate them at exactly the right places. So it's better not to use them, and to use a post processing script or a different slicer instead.



  • @dc42 Thanks

    Have implemented this and with the better acceleration and jerk extruder settings the retractions are happening in the right order; i.e. before the travel moves.

    @Phaedrux Am still getting bad stringing with your settings. 😞

    I get that this woody pla is not a good material to tune but my figuring is its best to tune with something that highlights the problem the most.

    I will however try some other filaments out and see what kind of results I can get form them..



  • I haven't used every brand of wood filament out there but I've used a few. Some are more stringy than others. But in general coping with it was always more than just retraction settings.

    I had to find a combination of retraction distance, pressure advance, print speed and temperature that gave fairly clean results and the rest came from slicer optimizing to try and reduce it further. Cura has a combing option that keeps the head inside the print area which can keep the ooze somewhat contained for single models. It even has some coasting options now that could help. I think simplify 3d has some wipe on travel options. And then there is always z hop with wipe.

    Temperature had a big effect. So try going through the whole range. For me bellow a certain point stringing really dropped off. But at the same time I found it printed best hot so it depends on the model whether stringing will be a problem or if you can get away with it. A bowl versus a statuette for example.

    The wood is also very hydroscopic compared to other PLA. If it's been out for a while it had probably taken in some moisture. Food dehydrator or very low oven to dry it back out might make a world of difference.

    Wood filament is my favorite to print with but it is a bit more tricky than most.



  • @phaedrux thanks for the useful info. Interesting..

    Do you find wood filaments abrasive on the nozzle?



  • @drammy that's what I've heard. I have only ever used hardened steel nozzles with it though, so I can't say from experience. The hardened steel has held up fine though.



  • @dc42 I'll second this, I set up firmware retraction on my delta two weeks ago, you really need to use post processing in order to get the G10 and G11 commands inserted into the right spot.

    The script is pretty simple, just use a known speed and distance and then post process to replace those moves with G10 and G11.

    http://thrinter.com/using-firmware-retraction-with-simplify3d/

    This will work well, but he's using absolute extrusion distances, so you'll need to edit his script a small amount.

    Just open a gcode file you've sliced in a text editor and double check the post processing has been done properly.



  • @dino Sorry, just seen your reply. I'm glad you suggested to check the post-processed g-code as it isn't right.

    Is it a problem that the G1 E command is on the same line as the X and Y? Also it shows as a different speed..?
    Can you share your post-process commands?

    This is what I have in my post-process commands:

    {REPLACE "G1 E-0.8000 F7200\n" "G10\n"}
    {REPLACE "G1 E0.0000 F7200\n" "G11\n"}
    {REPLACE "G1 E-0.8000 F2160\n" "G10\n"}
    {REPLACE "G1 E0.0000 F2160\n" "G11\n"}
    

    And this is part of the print file g-code

    G1 X82.117 Y86.207 E0.1197
    G1 X82.205 Y86.170 E0.0034
    G1 X82.605 Y86.170 E-0.8000 F3600
    ; outer perimeter
    G1 X84.145 Y90.645 F9000
    G1 X84.148 Y90.645 F9000
    G1 X84.150 Y90.650 F9000
    G1 E0.8000 F7200
    G1 X103.260 Y90.650 E0.6712 F2304
    G1 X103.260 Y109.760 E0.6712

Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.