Extruder Doesn't seem to change speed



  • I don't really understand what is happening here. I'm printing a test piece, just setting up my printer with the DuetWifi for the first time. The object is 100mm long and 5mm wide. When it prints, the long sides look ok, but the extruder doesn't seem to slow down on the short ends and I get big globs of plastic. Acceleration on the X and Y axis slow the head down when it's about to change direction but the extruder looks like it might even be speeding up. I can't prove that one way or the other at this time.

    I've tried adjusting steps/mm for the extruder but that didn't work.

    Any ideas?

    Here is my config.g file.

    ; Configuration file for Mini Kossel kit from Think3DPrint3D for testing Duet WiFi

    ; Communication and general
    M111 S0 ; Debug off
    M550 PNCC1701 ; Machine name and Netbios name (can be anything you like)
    M551 Preprap ; Machine password (used for FTP)
    ;*** If you have more than one Duet on your network, they must all have different MAC addresses, so change the last digits
    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED ; MAC Address
    ;*** Wifi Networking
    M552 S1 ; Enable WiFi

    M555 P2 ; Set output to look like Marlin
    M575 P1 B57600 S1 ; Comms parameters for PanelDue

    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves

    ; Axis and motor configuration
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M574 X1 Y1 Z1 S1 ; set endstop configuration (all endstops at high end, active high)
    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration
    ;M665 R105.6 L215.0 B85 H240 ; set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; put your endstop adjustments here, or let auto calibration find them
    M350 X16 Y16 E16 I1 ; Set 16x microstepping with interpolation
    M92 X160.128 Y160.128 Z4000 ; Set axis steps/mm
    M906 X1000 Y1000 Z1000 E800 I60 ; Set motor currents (mA) and increase idle current to 60%
    M201 X800 Y800 Z15 E100 ; Accelerations (mm/s^2)
    M203 X15000 Y15000 Z100 E600 ; Maximum speeds (mm/min)
    M566 X1000 Y1000 Z30 E10 ; Maximum instant speed changes mm/minute

    ; Thermistors
    M305 P0 T100000 B3950 R4700 H30 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 T100000 B4388 R4700 H0 L0 ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction
    M305 P0 T100000 B4388 R4700 H0 L0 ; Put your own H and/or L values here to set the second nozzle thermistor ADC correction
    M570 S180 ; Hot end may be a little slow to heat up so allow it 180 seconds

    ; Fans
    ;M106 P1 H-1 ; disable thermostatic mode for fan 1
    M106 P0 T50 H1
    M106 P1 T50 H2

    ; Tool definitions
    M563 P0 D0 H1 F0 ; Define tool 0
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
    ;*** If you have a single-nozzle build, comment the next 2 lines
    M563 P1 D1 H2 F1 ; Define tool 1
    G10 P1 S0 R0 X36 Y0 ; Set tool 1 operating and standby temperatures
    M92 E50:50 ; Set extruder steps per mm

    ; Z probe and compensation definition
    ;*** If you have a switch instead of an IR probe, change P1 to P4 in the following M558 command
    ;M558 P1 X0 Y0 Z0 ; Z probe is an IR probe and is not used for homing any axes
    ;G31 X0 Y0 Z4.80 P500 ; Set the zprobe height and threshold (put your own values here)

    ;*** If you are using axis compensation, put the figures in the following command
    ;M556 S78 X0 Y0 Z0 ; Axis compensation here

    M208 S1 Z-0.2 ; set minimum Z
    ;
    T0 ; select first hot end


  • administrators

    I'm guessing that you have a long Bowden tube between the extruder drive and the hot end. Try enabling pressure advance.



  • No, I have direct drives. Looks like it was because the slicer I was using (CraftWare) does not support relative extruder positions. I switched to Slic3r and I was able to get it to work.

    Thanks for all your help.



  • @dc42:

    I'm guessing that you have a long Bowden tube between the extruder drive and the hot end. Try enabling pressure advance.

    What is :pressure advance" - and how do you enable it?


  • administrators

    Pressure advance adds a term to the extruder drive position that is proportional to the extrusion speed. This helps to make the extrusion rate from the nozzle more accurately match what the gcode commands during acceleration and deceleration. You control it using the M572 command.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.