Struggling to understand z-offset and using Simplfy3D



  • I have gone through the process of setting the IR Zprobe and the nozzle leveling to 0 Z point using the paper method - and that all seems to be working fine.

    However, when I go to print after slicing in S3D the nozzle never positions to the 0 Z point.
    It defaults to Z .27 and when looking in the g-code of the sliced file I see this:

    G90
    M82
    M106 S0
    G28 X0 Y0 Z0 ; home all axes
    G29 ; probe the bed
    G1 Z30 F5000 ; lift nozzle
    M109 S235 ; set the extruder temp and wait
    G92 E0
    G1 E-3.0000 F2400
    G1 Z1.050 F1002
    ; layer 1, Z = 0.27
    T0
    ; tool H0.300 W0.900
    ; skirt
    G1 X72.644 Y79.826 F4800
    G1 Z0.270 F1002

    I don't see where the .27 is coming from in S3D .. if I set the z-offset in S3D to some negative number (e.g. -.09) then the line in the g-code will change accordingly:
    G1 Z0.180 F1002

    I guess I was assuming if I left the z-offset in S3D to '0' - then the g-code would set the code to something that would work closer to the 0 Z position.

    If anyone with more experience with S3D can help me out here … do I just need to set the z-offset in S3D to -.27? .. which of course I can, I just didn't understand where that is comeing from in S3D.



  • What is you default layer height and you first layer settings for that print?



  • Just to be clear, Z offset in S3D you are seeing has nothing to do with the Z offset for the z-probe specified in the config file for Duet. You can set global z-offset in s3d, if needed. However, I guess that you are trying to print with 0.3mm layer, and the 1st layer height is set to 90%, which would give you 0.3-0.03=0.27mm layer height for the 1st layer. The idea for this is to increase adhesion to the bed. The setting is found in the "Layer" tab.



  • That makes total sense now where S3D comes up with the .27 - I apologize for my ignorance.

    It appears then, that I have some issues I need to re-calabrate for my nozzle and bed leveling to reset my z height in the config file.

    Thanks.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.