Did I just burn a driver?



  • I just bought a duet wifi the other day to upgrade from my ramps 1.4 setup. Wired it up to my ATX power supply with external 5v and ps_on. Works perfectly. Wired the endstops. Still works nicely, easy install wiring is so much nicer than the ramps board. Now comes the not-so-fun part... I connected my y-motor to driver 1. I try to move my y-axis in the console but all I get is a small "poof", burnt electronics smell, and a message "short to ground on driver 1". So I am guessing I burnt this driver.... 😞
    How did this happen? This is an MPCNC machine that worked fine on the ramps board for over a year. Motor wiring has not changed. Power wiring is fine, endstops work but the driver just went poof when I tried to move the y-axis! I have not changed anything in the config file as of yet so I should only be driving the motors with 800ma. I have 2 self-built printers and one cnc machine so I think I have plenty of experience and I do not think I made a misstake, even though this is my first duet board.

    Can this be covered by warranty or is this a "crap, I burnt €150 and I need to get a new one" situation?

    /Carl


  • administrators

    This sounds like a driver infant mortality failure (rare these days), which is covered by the warranty. But please check that there are no short circuits in the Y motor wiring, either between adjacent pins of the stepper motor cable or between the cable and ground.

    Is there a burn mark on the Y stepper driver chip?



  • Thanks for the quick reply.

    Yes, I have a small burn marked on the attached image. I find no short between the stepper connections and ground. I have around 2 ohms on each coil and that is close enough to what the specs on my motors say.

    0_1531931812533_20180718_183534_resized.jpg


  • administrators

    Thanks, please see https://www.duet3d.com/warranty to make a warranty claim.


Log in to reply