Unable to update PanelDue firmware



  • I have just tried to update my new PanelDue7i firmware and bossac reports it cannot find the device on the appropriate port.

    I carried out the normal procedure of erasing, restting, and then trying upgrade with bossac. The same procedure works properly on all my earlier versions of paneldue. I am using windows 10 and the only other novel feature is the the pc restarts when I pull the usb plug out. Presumably because the load is so high.

    Anyone any ideas?


  • administrators

    Perhaps you are using an old version of bossac? You need 1.8, the latest.



  • Many thanks that was the problem



  • I also having a problem, I get an error when I run the newest 64bit version: "Caught Unhandled, unknown exception, terminating". Also running running Bosac.exe from your github just quickly flashes a window and disappears. Win10. ANy other options?



  • @wmmc01

    The bossac program needs to be ran via command line.

    https://miscsolutions.wordpress.com/paneldue/

    “Testing the board and updating the firmware”

    open command prompts, then run this command

    "C:\Program Files\BOSSA\bossac.exe" --port=COM9 -e -w -v -b PanelDueFirmware.bin

    changing the file path and file name and path as required.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.