DWC disconnects on file upload



  • Not sure if this is an issue or just how it is, but whenever I upload new firmware of a config.g file DWC will wait a while then disconnect. I have to wait a few seconds after that before I can reconnect. If I try to re-connect too quickly, it won't work. It's always been like that and it's no big deal but I'm just wondering if there is anything I can change in the communication or re-connect preferences that will help. I'm just using the default values. Connect automatically is ticked, status update interval is set to 250, max number of AJAX retries is 1, reconnect delay on halt is at 10, reconnect delay on firmware update is at 20. I'm using Firefox on Windows 10. Current firmware is now

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet Ethernet 1.0 or 1.01 + DueX5
    Firmware Version: 2.01(RTOS) (2018-07-26b2)
    Web Interface Version: 1.21.2-dc42


  • administrators

    I've not heard of that happening before. Some suggestions:

    1. When you run M122, how much "Never used RAM" does it report? You have a complex configuration, so it's possible that you might be running out of memory.

    2. Have you tried a new SD card? In case the old one is taking too long to do wear levelling when you write files.



  • @dc42

    1. M122 reports Never Used Ram as 5320

    2. New SD card makes no difference. If it's any help, M122 reports interface speed 20.0MBytes/sec, longest block wrote time 4.0 ms, max retries 0. I usually get just over 1.0 MiB/sec reported upload speed (depending on fie size). Duet Ethernet on Gigabit Lan with cat 5e/6 cable.

    I've tested again and taken more note of what actually happens. I upload a config.g file and get the pop up message "Would you like to reboot. Click Yes. The machine re-boots, DWC seems to freeze, then about 10 seconds later DWC disconnects and reports this:

    Request timeout.
    The last HTTP request timed out - etc etc

    I give it a few seconds hit "Connect" and everything is fine and dandy.

    The only thing I could see in DWC settings that is set to 10 is Reconnect Delay on Halt so I changed it to 20 but that didn't have any effect.


  • administrators

    It sounds like your board is taking longer than usual to run config.g and establish the network connection (the network is not started until config.g has been run). If you are using DHCP to assign the Duet an IP address, you may get a clue if you watch the LEDs on the Ethernet socket to see when the DHCP traffic starts.



  • I'd say it's about 5 to 6 seconds after hitting "Yes" to reboot that the green LED on the board network connector starts to flash. Is that too long, normal or what?

    I am using M552 P0.0.0.0 to acquire dynamic address via DHCP. Would setting a fixed IP address help?


  • administrators

    @deckingman said in DWC disconnects on file upload:

    I am using M552 P0.0.0.0 to acquire dynamic address via DHCP. Would setting a fixed IP address help?

    Only if your router and the Duet are taking a long time to agree on an IP address. This will happen if the router is slow to assign an address, or if it assigns an IP address but the Duet determines discovers that IP address is already in use.

    6 seconds is rather long. Do you have any movement or delay commands in config.g?



  • Router is set to always use the same IP address for the Duet so it's a sort of fixed IP address.

    No movement or delays in config.g but it is a largish file (CoreXYUV with 5 extruders, 8 thermostatic fans and some other gubbins). An example of my config.g is in the folder that I created on my Google Drive for the pressure advance stuff https://drive.google.com/drive/folders/0B_MwtHtQR_Zvd1BSd1RKSFYwbTQ?usp=sharing



  • Had a similar issue when I got my duet.

    It was a corrupted SD. After changing it works like a charm!



  • Well I've tried an assortment of SD cards including a brand new one and in sizes varying from 4GB to 32GB. I even reformatted the smaller one using FAT16 with 64kb cluster sizes instead of the usual FAT 32 with 32KB cluster sizes. None of which makes any difference. I changed to Chris Ham's latest version of DWC (1.22 b3) which still exhibit the same behaviour but at least it automatically re-connects after a period of time without me having to do anything. I guess it must just be something to do with my large and complex config.g file(s). Not a huge problem and I can live with it.....


  • administrators

    @deckingman, when you run M122, now much Never-used RAM is reported?



  • @dc42 said in DWC disconnects on file upload:

    @deckingman, when you run M122, now much Never-used RAM is reported?

    As per my post above of 27th July. Trying to do this on my'phone and I can't get to that post as I type this but IIRC it was around 5,300.


Log in to reply