Bed leveling assistant not responding



  • Can anybody give some advice on how to get somewhere with the levelling assistant that pops up whenever I go to print a file? I'm using a DuetWifi with the latest firmware and web software, controlled from my laptop. My printer's a DIY i3 clone cartesian. I don't have an automatic bed probe.

    When I run the z home an assistant pops up and I can control the Z axis with the buttons and lower the head until it's gapped properly with a sheet of paper. I can even run the mesh compensation probe and probe for multiple points.

    when I queue up a print the bed levelling assistant pops up but the controls don't work, I can't move the printer head. The head is raised very high off the bed while it's doing this so I can't gap it with a piece of paper.

    My bed is square with a manual m3 screw at each corner.

    I looked over the documentation and saw that bed.g has to have S4 at the end for 4 screws. I also have an M671 at the end of config.g listing the locations of each of the 4 levelling screws with a P0.5 at the end for 0.5 pitch for m3 screws.

    I've attached the config files which should be pertinent.

    0_1532842056838_bed.g
    0_1532842068106_config.g
    0_1532842074008_config-override.g
    0_1532842090753_homeall.g
    0_1532842097871_homex.g
    0_1532842105881_homey.g
    0_1532842111241_homez.g


  • administrators

    As you don't have a Z probe, do you have a Z endstop switch? If so, see item #1 on the wiki FAQ page.



  • Thanks @dc42 that got me further. Now I'm running into a problem where the G92 command at the end of the homing of the z axis isn't setting the z position properly.

    If I execute the following gcode commands in the console this is what I get:

    G92 Z0.1
    M114
    X:20.000 Y:20.000 Z:1.000 E0:0.0 E1:0.0 E2:0.0 E3:0.0 E4:0.0 E5:0.0 E6:0.0 E7:0.0 E8:0.0 Count 2000 2000 400 Machine 20.000 20.000 1.000

    Because it thinks it's at 1mm after the homing the first layer is printed incorrectly. What do I have to do to correct the homing?

    Here's my home z file:

    G91 ; relative positioning
    G1 Z10 F200 S2 ; raise head 10mm to ensure it's above switch trigger height
    G90 ; back to absolute
    G1 X20 Y20 S2 F2000 ; put the the head where you want it to be when you home z
    G91 ; back to relative move
    G1 Z-200 S1 F100 ; move z down until the switch triggers
    G90 ; back to absolute mode
    G92 Z0.1 ; tell the firmware that we are at z=0.1mm, the width of the paper used for homing (measured with calipers)



  • Never mind, i figured it out. The reprap firmware configuration assistant was using M208 to set the minimum z height to 1mm. I changed it to 0mm and now when i run the calibration I'm getting 0.1mm as expected.

    To be honest, the configuration assistant was more trouble than help. I'd almost recommend not suggesting it in your documentation.



Looks like your connection to Duet3D was lost, please wait while we try to reconnect.