Cannot calibrate this delta!



  • I have an anycubic kossel linear plus. Day one, after assembly, flawless benchy. I have a zesty nimble extruder left over from another build that fell through, so I install that. I upgraded the drivers to TMCs and flash the trigorilla board with klipper firmware controlled by a pi running octoprint. I install a PEI shet on the bed since the buildtak that came with the machine tore off too. It took a lot of work but in the end, it was perfect. At the start of the day, I send DELTA_CALIBRATE, input those results into printer.cfg and restart the host, ant it runs fine.

    Now you have the backstory and know the past known-good configuration.

    Since then, the mendel machine the duet wifi was in broke down and I no longer wanted to fix it. I also hate octoprint. Duet's webUI will do weird things, like disconnect or rehome the printer when I switch back to the duet tab and let it reload, stopping a print, but thats nothing compared to the million ways octoprint freezes and annoys me. In addition, I like that I can let the duet probe and save its own results with an M500 rather than having to ssh into a linux host and type it all out. The duet should be easer, right? So I install that and optical endstops.

    Now you know what I did and how I got where I am.

    Now, I cannot get the delta to probe and print properly. I tried different calibration factors, adding and removing probe points. I have found I get the best results probing 3 outer points and 3 inner points (plus the center) with 6 factor calibration. It runs the probe, I send M500, remove the probe from under the hotend, and tell it to print.

    It homes, and while I see this is a point of failure, it id not have that trouble while running klipper. It's not likely the new endstops as the issue happens consistently. So my issue: I cannot get a clan print on my delta since installing the duet.

    Here's some photos showing my machine's attempt to put down a circle.
    ![https://imgur.com/4gRI8Ge](image url)
    ![https://imgur.com/qwv9kJR](image url)
    ![https://imgur.com/NPofXJT](image url)
    ![https://imgur.com/PKH3VDX](image url)
    ![https://imgur.com/N2LzoaN](image url)


  • administrators

    7 points isn't really enough for 6-factor calibration to work well. Use at least 6 points around the periphery. More points is better, even if it increases the reported deviation.

    After calibration you can run mesh bed probing to get the height map - that will tell you how well your delta is calibrated.



  • I didn't use mesh before as I never needed to. When I tried it here, it showed everything but the edges were pretty even, and the edges were flared up.


  • administrators

    You don't necessarily need to use mesh bed compensation while printing (I don't), however running it will display the height map in DWC, which shows you how good the calibration is and can identify particular problems.



  • 16 points now. Mesh looks like a mess now.
    https://youtu.be/ayMw_tUYCTg


  • administrators

    You have two high points at the periphery of the height map which indicate a particular problem at high rod angles, possibly insufficient movement of the joints. If you are using a similar probing radius during calibration as you are for the height map, this will be throwing off your calibration too. So I suspect that you are trying to calibrate using a larger probing radius than you used before you installed the Duet.



  • I thought of that already, and shrunk the probable area smaller. the radius here is set to 100, and it's 115 on klipper.



  • I set up klipper on this again and I'm having the same problem. Its not quite as severe but I think that's just from previous tweaking helping here.

    I'm thinking those optical endstops were not the improvement I thought they would be. I'd going to reinstall the mechanical endstops and report back what happens.

    EDIT: It deleted config.g again and it printing a few mm above the bed. I'll undelete the file and try again. tomorrow. This machine has exhausted me. Interestingly, its pretty consistent distance from the build plate inspires confidence.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.