BL Touch issues



  • After accidentally shorting a stepper motor, I got my replacement today and have everything up and running. X and Y axes home just fine.

    I've followed the guide here:

    https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_If_you_don_t_have_a_DueX2_or_DueX5_expansion_board

    To set up my BL touch. When I turn my printer on, it does the little test where the probe deploys and retracts twice. The problems start when I run the M280 command -- it does nothing. I've confirmed everything is plugged in correctly and as mentioned, the test works fine.

    I'll post my config.g file below. The ONLY thing I can think of is that maybe I didn't fully cut the logic controller on the BL touch or something -- it's really hard to see so I can't really tell. Would that cause the issues i'm describing? Is there anything I can do to figure out if it's defective?

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 PMy printer ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M584 X0 Y1 Z2:4 E3 ; Apply custom drive mapping
    M350 X16 Y16 Z16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z1600 E420:1600 ; Set steps per mm
    M566 X900 Y900 Z12 E120:12 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200:180 ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250 E250:250 ; Set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E800:1200 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X330 Y330 Z400 S0 ; Set axis maxima

    ; Endstops
    M574 X1 S1 ; Set active high endstops
    M574 Y1 S0 ; Set active low endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F100 T2000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 X-41.8 Y32.2 Z0 P25 ; Set Z probe trigger value, offset and trigger height
    M557 X15:315 Y15:315 S20 ; Define mesh grid

    ; Heaters
    M140 H-1 ; Disable heated bed
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C



  • Also, if I manually pull out the pin, the red light goes off. Whether the pin is up or down the Z-probe status reads as 0.



  • One of my other thoughts: maybe since I used the M140 command to disable the heated bed, it's interfering with me using the heater channel?



  • Ok, the probe self-testing only means it’s powered properly not wired properly, well not completely anyways.

    Can you take take a picture of your wiring? Also what version of the board do you have?

    Also you disable heater 3 but set the probe to heater 5.

    Your code:
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F100 T2000 ; Set Z probe type to

    I need to see where your pwm line is actually connected and then you can set these two commands accordingly.

    Also did you create a deployprobe.g and retractprobe.g?



  • By the way, I found this guide to be the best. Note the wiring diagram may be off from the board you are actually using so make the connection based on how you have yours wired.

    https://betrue3d.dk/bltouch-on-duet-wifi-configuratio-and-usage/



  • Er, I thought the H in M558 is the dive height?

    "Pnnn Z probe type
    Fnnn Feed rate (i.e. probing speed, mm/min)
    Hnnn Dive height (mm)
    Innn Invert (I1) or do not invert (I0) the Z probe reading (RepRapFirmware 1.16 and later)
    Rnnn Z probe recovery time after triggering, default zero (seconds) (RepRapFirmware 1.17 and later)1
    Tnnn Travel speed to and between probe points (mm/min)
    Annn Maximum number of times to probe each point, default 1 (RepRapFirmware 1.21 and later)
    Snnn Tolerance when probing multiple times, default 0.03 (RepRapFirmware 1.21 and later)
    Bn B1 turns off all heaters during probing moves and during the probe recovery time (RepRapFirmware 1.21 and later)"



  • Doh! Right you are. Can you post your deployprobe.g and retractprobe.g files? They need to be in the same spot as the config file

    Also are you 100% sure the wire is in heater3? Make sure you use the correct wiring diagram as the guides can be outdated.



  • @bpislife I actually used that guide first, but when it wasn't working properly I went back to the duet guide and tried that.

    I'm using the Duet Wifi -- I just bought it new a month ago from Filastruder.

    deployprobe.g:

    ; deployprobe.g
    ; called to deploy a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Jul 29 2018 11:50:39 GMT-0400 (Eastern Daylight Time)
    M280 P3 S10 I1

    retractprobe.g:

    ; retractprobe.g
    ; called to retract a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Jul 29 2018 11:50:39 GMT-0400 (Eastern Daylight Time)
    M280 P3 S90 I1



  • @kskiff7034 Ok, so can you double check that you have yellow plugged into Heater3 (pin 8 ) on the large header? If so, can you send this command in the console: "M280 P3 S10 I1"



  • As for wiring, I have it set up exactly as it appears in this picture:

    https://d17kynu4zpq5hy.cloudfront.net/igi/duet3d/KUDxTZSs3rnd3JVH.standard

    I also tried the other version of setup from the guide that you posted using Heater 7 (Pin 31).



  • @kskiff7034 Ok. Did you cut the 5V line on the back of the bltouch? Also did you send that command manually to the bltouch?



  • I did cut the 5v line, but like I said in the original post I can't really tell if it's actually "cut". I used an xacto blade and ran over it quiet a few times, but it's so small you can't really see it. And yes, I sent it manually in the duet browser window in G-Code Console. I've also tried using a macro.



  • This post is deleted!


  • I have a multimeter but I'm not very experience with it. I've used it a handful of times to test different things but wasnt sure how to do so on the BL touch.



  • @kskiff7034 Take a resistance measurement across the two exposed pads (on either side of your cut). The resistance should be large.



  • This'll take awhile. Getting the BL touch off is kind of a pain. Will report back in a bit.



  • @kskiff7034 Ok. It can be frustrating at first. It took me several hours the first time to figure out everything I was doing wrong. I have 4 of them working on my various printers. While its apart triple check your connection, your crimps, etc.



  • @bpislife So with the multimeter set to 200, touching the 2 pads causes the numbers to jump around wildly before settling on .4 for a few seconds and then dropping to .3



  • Setting it to 2000, 20k, 200k, and 20m cause it to jump around wildly before settling at 0, but setting it to 200m it settles at .9? So confused.



  • Ok so I'm having doubts about whether I cut the pcb trace correctly.

    Looking at this image:

    https://static.wixstatic.com/media/f5a1c8_11bd24d2d4974b2998c8d2a6736df1b3~mv2.png/v1/fill/w_637,h_308,al_c,lg_1/f5a1c8_11bd24d2d4974b2998c8d2a6736df1b3~mv2.png

    Am I supposed to cut the little line between the two pads, or one of the lines near 5 or 6? I thought it was the line between the two pads, but now I'm not sure.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.