Attempted to update firmware, Bossa will not work.



  • My 5 inch paneldue v3 needed a firmware re-install after an accidental erase button press at some point during its storage. Downloaded the appropriate bin file and I am trying to use Bossa 1.8 (GUI Version) to install it with no success. Here is what the GUI looks like0_1533743767343_Bossa GUI.PNG
    I am running 64 bit windows 7. Perhaps I am pressing the wrong buttons? Or in the wrong order?



  • If you press the refresh button at the top do you get more options for serial port?

    Do you have a different USB cable to try?

    Try plugging the device in before opening Bossa.



  • 0_1533745286751_Confirm.PNG
    Here is confirmation it is using the right port. I have tried 2 different cables so far and have tried various orders of connecting and opening etc. including connecting the board before I open Bossa, which is the only way it will read the correct port.



  • Have you pressed the erase and reset buttons to make it flashable?

    Press and hold the Erase button of the PanelDue for at least one second. You can access this button by pressing the end of a straightened-out paper clip through the hole in the enclosure.
    Release the Erase button, then press and release the Reset button. If you have a version 2.0 board then the backlight will turn off.

    https://miscsolutions.wordpress.com/paneldue/



  • Every time I try I do. I've been following this guide. Looks to be the same as the one you are referencing.



  • @brmatt Yes it's the same.

    The only time I've had issues such as you describe is when I haven't pressed the erase and reset buttons correctly, or the usb cable isn't of good quality.

    Sometimes windows will prevent usb devices from being recognized. Try unplugging the usb cable, rebooting the system, and then plugging the usb cable into a different port.



  • Got it. Thanks for the help. I will try a new cable, port, and make sure i hit the buttons correctly, although I believe I have been the whole time but I will be extra thorough and report back. What order do you press the buttons in. I've tried a variety. I would think write and then verify, but I have also tried read-write-verify as well as write-read-verify and just read-verify.



  • Just write and verify, I don't think I've ever used read. Don't forget to hit the reset button again after verify has been completed.

    At one point I had completely swapped the buttons in my mind. When I thought I was pressing reset I was actually pressing erase. So make sure to check the labels on the PCB for each button.



  • Ok that is what i figured. I'm fairly positive I have been clicking everything correctly. I'm worried perhaps the LCD screen is dead. It doesn't light up at all when connected to power, pre or post reset. I've checked all the connections and they seem alright. Should it light up even just white at any point in this process?



  • Are you sure you have the correct firmware for your board? I have seen it not light up at all if I have used the wrong version before. I was still able to reflash to the correct version afterwards.

    Have you been able to successfully flash the firmware using this computer in the past? It's possible the USB port isn't providing enough power.


  • administrators

    That screen looks OK to me. What happens when you press Write? If it reports success, what happens when you press Verify?

    Check the size of the downloaded file. It should be around 181kb.



  • fairly positive. I know the paneldue is a V3 and the screen is 5 inches. From upper left to bottom right corner it is 5 inches.

    This is my first time programming it. I had "success" when I tried the 4 inch firmware in that it lit up, however it the screen mirrored horizontally for half the screen and the other half had broken rainbow lines on it.



  • This is the screen for write:
    0_1533750408073_write.PNG

    Here is verify:
    0_1533750421780_verify.PNG

    And here is the file I am uploading:
    0_1533750437665_file.PNG


  • administrators

    Your downloaded file is 256kb long, whereas the official release binary at https://github.com/dc42/PanelDueFirmware/releases is 181kb. As the processor has only 256kb of flash memory, my guess is that either you have a corrupt file, or you have appended your own splash screen to the -nologo version and in doing so made the file slightly too long because your splash screen doesn't compress well.



  • That was it! I didn't add a splash screen (don't even know how to) so it must have corrupted at some point. I'm very glad this is solved though. Thank you!


  • administrators

    I'm glad you solved it. In RepRapFirmware we do a quick check on the firmware binary to avoid installing an obviously bad file, but unfortunately Bossa can't really do that because it has to be more general.



  • Gotcha. I'll keep an eye out for stuff like that in the future. Thanks again.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.