Motors much louder than on MKS+TMC2208



  • Dear All.

    I had a hard time to pay the price for my duet wifi. Until now i only have the board itself.
    My printer is a tronxy X3s, which is a CR 10 clone.

    Before switching to duet i used MKS 1.4 with TMC2208 drivers. It was not noticeable, even if the drives were moving.( slower than 50mm/s)
    Now with duet wifi i have whining noise during idle and a lot louder movement sounds in comparision to MKS + TMC2208.

    I have seen many threads pointing to wiring/lower current and such. So the only thing changed here is the duet board as the motors were
    quiet before. In result i wont bet on wiring as the documentation is very good for duet. What can i do?

    Stepper motors are 1.8° "Chinesian Brand". here is my configuration:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Aug 13 2018 00:16:32 GMT+0200 (Mitteleuropäische Sommerzeit)
    
    ; General preferences
    G90                            ; Send absolute coordinates...
    M83                            ; ...but relative extruder moves
    
    ; Network
    M550 PRainer                   ; Set machine name
    M552 S1                        ; Enable network
    M587 S"Funkefiez 2" P"d3rd1gg3"; Configure access point. You can delete this line once connected
    M586 P0 S1                     ; Enable HTTP
    M586 P1 S1                     ; Enable FTP
    M586 P2 S1                     ; Enable Telnet
    
    ; Drives
    M569 P0 S0                     ; Drive 0 goes backward - X
    M569 P1 S0                     ; Drive 1 goes backward - Y
    M569 P2 S1                     ; Drive 2 goes forwards
    M569 P3 S1                     ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 S3		; Configure microstepping with interpolation
    
    M92 X80 Y80 Z400 E95.2         ; Set steps per mm
    M566 X15 Y15 Z2 E2               ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z300 E3000    ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z100 E1000    ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I40   ; Set motor currents (mA) and motor idle factor in per cent
    M84 S0                       ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1               ; Set axis minima
    M208 X300 Y300 Z300 S0         ; Set axis maxima
    
    ; Endstops
    M574 X1 Y1 S0                  ; Set active low endstops
    
    ; Z-Probe
    M574 Z1 S2                     ; Set endstops controlled by probe
    M558 P1 H5 F120 T6000          ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X35 Y5 Z2             ; Set Z probe trigger value, offset and trigger height
    M557 X40:280 Y20:280 S20       ; Define mesh grid
    
    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120                   ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280                   ; Set temperature limit for heater 1 to 280C
    
    ; Fans
    M106 P0 S0.3 I0 F500 H-1       ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45      ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45      ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1                  ; Define tool 0
    G10 P0 X0 Y0 Z0                ; Set tool 0 axis offsets
    G10 P0 R0 S0                   ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Automatic saving after power loss is not enabled
    
    ; Custom settings are not configured
    

    As its done my config creation tool its very stock. I tried to set S3 on M350 as it feels that its not using stealthchop? Nothing changed.

    Thanks
    derdigge

    EDIT: added codeblock.


  • administrators

    Use S1 to enable interpolation.

    Motor idle noise can often be reduced by changing the off-time in the stepper driver configuration. There is a thread about how to do this (search for "motor idle noise"). It's even easier in the new 2.02beta1 firmware, because there is a separate M569 parameter to set the off time.



  • @stephan said in Motors much louder than on MKS+TMC2208:

    As its done my config creation tool its very stock. I tried to set S3 on M350 as it feels that its not using stealthchop? Nothing changed.

    Duet Wifi does not support stealthChop but only spreadCycle. I am not sure what will be selected when you use S3 here but I guess it will fall back to spreadCycle.

    As to reducing stand-still noise as @dc42 mentioned look at [Reducing Stand-Still Noise].(https://duet3d.dozuki.com/Wiki/Reducing_Stand-Still_Noise).

    What are the specs of your motors? Especially rated current, resistance and inductance?



  • Thanks for the answers.

    @dc42 said in Motors much louder than on MKS+TMC2208:

    Use S1 to enable interpolation.

    Motor idle noise can often be reduced by changing the off-time in the stepper driver configuration. There is a thread about how to do this (search for "motor idle noise"). It's even easier in the new 2.02beta1 firmware, because there is a separate M569 parameter to set the off time.

    Forgot to mention, i am allready on latest beta.

    @wilriker said in Motors much louder than on MKS+TMC2208:

    @stephan said in Motors much louder than on MKS+TMC2208:

    As its done my config creation tool its very stock. I tried to set S3 on M350 as it feels that its not using stealthchop? Nothing changed.

    Duet Wifi does not support stealthChop but only spreadCycle. I am not sure what will be selected when you use S3 here but I guess it will fall back to spreadCycle.

    As to reducing stand-still noise as @dc42 mentioned look at [Reducing Stand-Still Noise].(https://duet3d.dozuki.com/Wiki/Reducing_Stand-Still_Noise).

    What are the specs of your motors? Especially rated current, resistance and inductance?

    Hard to say about the specs. They are stock tronxy and no data available. They are Nema17 40mm long.
    nothing googleable.(i know that this do not help)
    Duet wifi does not support stealthChop ? Seriously?

    regardig to this:
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M350_Set_microstepping_mode
    There is a switch?

    EDIT added board diag:

    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.01beta2(RTOS) running on Duet WiFi 1.02 or later
    Board ID: removed
    Used output buffers: 3 of 20 (7 max)
    === RTOS ===
    Static ram: 28484
    Dynamic ram: 95996 of which 0 recycled
    Exception stack ram used: 324
    Never used ram: 6268
    Tasks: NETWORK(ready,328) HEAT(blocked,1248) MAIN(running,3592)
    Owned mutexes:
    === Platform ===
    Last reset 00:01:56 ago, cause: software
    Last software reset at 2018-08-13 15:36, reason: User, spinning module GCodes, available RAM 6284 bytes (slot 0)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 50.5, current 50.7, max 51.0
    Supply voltage: min 24.1, current 24.2, max 24.4, under voltage events: 0, over voltage events: 0
    Driver 0: standstill, SG min/max 41/128
    Driver 1: standstill, SG min/max 0/185
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2018-08-13 15:38:45
    Slowest loop: 7.42ms; fastest: 0.07ms
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 239, MaxWait: 11369ms, Underruns: 0, 0
    Scheduled moves: 28, completed moves: 28
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 9.19ms; fastest: 0.01ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8
    - WiFi -
    Network state is running
    WiFi module is connected to access point 
    Failed messages: pending 0, notready 0, noresp 0
    WiFi firmware version 1.19
    WiFi MAC address 60:01:94:7e:eb:a8
    WiFi Vcc 3.10, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 37360
    WiFi IP address 192.168.2.120
    WiFi signal strength -44dBm, reconnections 0, sleep mode unknown
    Socket states: 0 0 0 0 0 0 0 0
    === Expansion ===
    


  • @stephan said in Motors much louder than on MKS+TMC2208:

    Hard to say about the specs. They are stock tronxy and no data available. They are Nema17 40mm long.
    nothing googleable.(i know that this do not help)

    OK, I know this from my motors (coming from an Anet A8).

    Duet wifi does not support stealthChop ? Seriously?

    regardig to this:
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M350_Set_microstepping_mode
    There is a switch?

    Yes, there is a switch but the documentation also says

    the Duet 2 Wifi/Ethernet supports modes 0, 1 and 2.
    The Duet 2 Maestro supports modes 2 and 3

    Where 2 is spreadCycle and 3 is stealthChop.

    So as you can see stealthChop is only supported with the Duet Maestro as it uses different drivers (TMC2240 IIRC). TMC2660 as used on Duet Wifi/Ethernet do not support stealthChop.



  • Damn. i wish i had read further...

    This is a dealbreaker for me.


  • administrators

    As you are using the latest beta, try reducing the off-time using the new F parameter of the M569 command. For example, send M569 P0 to find the current parameters of the X motor, and M569 P0 F# to change the off-time, where # is the new off-time.



  • Thanks for the helping hands here, really.
    After few days of testing i am sure i will go back. The Gcode driven System and the Webinterface are really great.

    It prints currently on my tronxy but its simply to loud. I tried an stepper from stepper online on y axis i have arround but its the same.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.