Printer prints mirror of model? How do I fix this?



  • My printer is running a Duet wifi board and its printing a mirror of the model. Take a look at these pictures. Notice the ports on the side of the model in the screenshot from the slicer are opposite of what printed (print is backwards). I'm guessing it has something to do with having a coordinate system set up wrong in the config file but I'm not totally sure. This is what my config file looks like.

    ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Jul 09 2018 14:02:55 GMT-0600 (Mountain Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P0 ; Set firmware compatibility to look like native output

    ; Network
    M550 PFT5 ; Set machine name
    M551 P**** ; Set password
    M552 S1 ; Enable network
    M587 S"" P"" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X256 Y256 Z256 E256 I1 ; Configure microstepping without interpolation
    M92 X1290 Y1290 Z6360 E6697 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z1500 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X900 Y900 Z1200 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X300 Y300 Z400 S0 ; Set axis maxima

    ; Endstops
    M574 X2 Y1 Z1 S0 ; Set active low endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:285 Y15:285 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S220 ; Set temperature limit for heater 0 to 220C
    M305 P1 X200 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S350 ; Set temperature limit for heater 1 to 350C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not configured



  • As outlined in the FAQ:

    My prints come out mirrored

    3D printers must be configured to use a right-hand coordinate system. If you have configured your printer to use a left-hand coordinate system, your prints will come out mirrored.

    Looking at the front of the printer. the most common arrangement using a right-hand coordinate system is:

    +X moves the print head to the right
    +Y moves wither the print head away from you (towards the rear of the printer), or the bed towards you (towards the front of the printer)
    A few printers (e.g. the Ormerod) have +X moving the head towards you, and +Y moving either the head to the right or the bed to the left.

    On a delta printer, the X tower should be on the left, the Y tower on the right, and the Z tower at the back.



  • So the y axis stepper was backwards and I have corrected that so now y+ movements are towards the back of the printer. However, my Y endstop is at the y max side of the printer, but when I home the y axis, it moves in y-. How do I reverse this or tell the printer that the y endstop is on the other side of the axis?



  • I changed the homing direction for the y axis in homey and homeall, but the printer hits the y endstop and wont back up to hit a second pass. The stepper just keeps going even though the endstop is triggered (just jumps the belts or stalls the stepper). I think I have the homing file correct.
    Here is what it looks like

    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Jul 09 2018 14:02:55 GMT-0600 (Mountain Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 Y305 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y-5 F6000 ; go back a few mm
    G1 S1 Y305 F360 ; move slowly to Y axis endstop once more (second pass)
    G1 Z-5 F6000 S2 ; lower Z again
    G90 ; absolute positioning

    homeall file is similar.



  • Figured it out. I had the y axis min and max reversed in the config file.



  • Glad you worked it out!

    Cheers,
    Kris


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.