Solved: sudden problem with board/motors connection



  • TLDR; Problem in my config.g – Thank you DC42, your response about choosing tool made me look at the tool definition -
    After swapping in the 24v power supply and it still not working, I looked at the config file again. It turns out, I had copied someone else's who has a Diamond Extruder (something I have purchased but not installed yet) - I commented out the extra extruder tool definitions, but in doing so had also somehow removed the D0 parameter from the T0 definition.

    I am my own nemesis at times.

    I attempted to start calibrating this morning and somethings gone terribly wrong.


    Everything was just fine last night, and when I turned the power on this morning and booted everything up - it homed and hot end and bed heated up just fine.
    So, I disconnected and unplugged power. Hooked up the IR sensor, turned on power and reconnected. It wouldn't home all the way any more - it went 3/4 of the way to the top and then gave me the 'delta not homed error'.
    Then, the Y motor stopped working. I powered down, removed the y connectors, made sure they were seated properly, tested the motor (which is fine). I reconnected the Y motor and ALL the motors stopped working.

    Now just the Z motor moves. X stutters but doesn't go anywhere and Y doesn't move at all
    M906 gives me Motor current (mA) - X:1000, Y:1000, Z:1000, E:1250:1250:1250:1250:1250:1250:1250, idle factor 100%
    (E is a geared motor)
    G91 G1 S2 Z10 - Okay
    G1 S2 X10 - stuttering jerks but doesn't travel anywhere
    G1 S2 Y10 - No response

    I've got 12.36 V in for everything but the heated bed- (my heated bed is on another power supply - connected as instructed on the Wiki - e.g., there is no Vin connected to the Duet-Wifi)
    I always disconnect and remove power when I'm touching the board - I also wear a ground strap when I connect/disconnect wires.

    Below is a copy of my config.g - there's some extra commented out Hot End stuff because I intend to add a DIamond later.
    ; Configuration file for Mini Kossel kit from Think3DPrint3D for testing Duet WiFi

    ; Communication and general
    M111 S0 ; Debug off
    M550 PMiniKosselWiFiTest ; Machine name and Netbios name (can be anything you like)
    M551 Preprap ; Machine password (used for FTP)
    ;*** If you have more than one Duet on your network, they must all have different MAC addresses, so change the last digits
    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED ; MAC Address
    ;*** Wifi Networking
    M552 S1 ; Enable WiFi

    M555 P2 ; Set output to look like Marlin
    M575 P1 B57600 S1 ; Comms parameters for PanelDue

    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Axis and motor configuration
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M574 X2 Y2 Z2 S1 ; set endstop configuration (all endstops at high end, active high)
    ; Maximum instant speed changes mm/minute

    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration.
    M665 R134.5 L300 B140 H410 ; set delta radius, diagonal rod length, printable radius and homed height
    M666 X0.00 Y0.00 Z0.00 ; put your endstop adjustments here, as given by auto calibration 22/05/15
    M92 X75.07 Y75.07 Z75.07 ; Set axis steps/mm
    M906 X1000 Y1000 Z1000 E1250 ; remove comment when adding E1 :1500:1500:1500:1500:1500 Set motor currents (mA); set each extruder explicitly
    M906 I100 ; Set motor idle factor to 100% while testing so they don't idle at all
    M201 X1000 Y1000 Z1000 E1000 ; Accelerations (mm/s^2) Set all E-motors the same
    M203 X20000 Y20000 Z20000 E3600 ; Maximum speeds (mm/min) Set all E-motors the same
    M566 X1300 Y1300 Z1300 E1300 ; Maximum instant speed changes mm/minute. Set all E-motors the same
    M207 S5.0 F2400 : 5mm retraction at 2400mm.min (40mm/sec) for the all three extruders to prevent the Diamond Head ooze!

    ;PID Settings
    ;For manual adjustments: if it overshoots a lot and oscillates, either the integral gain needs to be increased or all gains should be reduced. Too much overshoot? Increase D, decrease P.
    ;Response too damped? Increase P. Ramps up quickly to a value below target temperature (0-160 fast) and then slows down as it approaches target (160-170 slow, 170-180 really slow, etc)
    ;temperature? Try increasing the I constant.

    M307 H1 A644.4 C205.4 D10.6 B0 S0.8
    M307 H0 A206.0 C281.1 D22.1 B0 S0.8

    ;M301 H0 P11 I0.04 D170 T0.50 S1.0 ; PID settings for Print Bed (-P means bang bang setting and not PID)
    ;M301 H1 P08 I0.20 D109 T0.50 S1.0 ; PID settings for Heater 1 (Diamond Hot)

    ; Thermistors
    M305 P0 T100000 B3950 R4700 H0 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 T100000 B4072 R4700 H0 L0 ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction
    ;M305 P2 T100000 B4072 R4700 H0 L0 ; Put your own H and/or L values here to set the second nozzle thermistor ADC correction
    M570 S280 ; Hot end may be a little slow to heat up so allow it 280 seconds

    ; Fans
    M106 P1 H-1 ; disable thermostatic mode for fan 1

    ;*** If you have a dual-nozzle build, un-comment the next 2 lines
    ;M563 P1 D1 H2 ; Define tool 1
    ;G10 P1 S0 R0 ; Set tool 1 operating and standby temperatures
    ;M92 E94.35 ; Set steps/mm for extruder 0.

    ;*** With a Duex4 add more tools: Here I have set up multiple tools for the Diamond with Nema 17 extruder steppers on Drivers 2, 3 and 4 using H1 heater

    M563 P0 H1 ; Define tool 0
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
    M567 P0 E1 ; .0:0.0:0.0 Set mixing to extruder 1 at 100%
    M568 P0 S2 ; Turn on mixing (1 = on, 2=off)
    M92 E476

    ;M563 P1 D2:3:4 H1 ; Define tool 1
    ;G10 P1 S228 R228 ; Set tool 2 operating and standby temperatures
    ;M567 P1 E0.0:1.0:0.0 ; Set mixing to extruder 2 at 100%
    ;M568 P1 S1 ; Turn on mixing (1 = on, 2=off)
    ;M92 E458.55:458.88:458.55:458.55:458.55 ; Set steps/mm for extruders 2, 3, 4, 5

    ;M563 PX D2:3:4 H1 ; Define tool X
    ;G10 PX S228 R228 ; Set tool X operating and standby temperatures
    ;M567 PX E0.X:0.X:0.X ; Set mixing for extruders 1, 2 and 3 each at X% (best to add up to 1.0)
    ;M568 PX S1 ; Turn on mixing (1 = on, 2=off)

    ;M563 PXX D5 H6 ; Define tool XX
    ;G10 PXX S0 R0 ; Set tool XX operating and standby temperatures

    ; Z probe and compensation definition
    ;*** If you have a switch instead of an IR probe, change P1 to P4 in the following M558 command
    M558 P1 X0 Y0 Z0 ; Z probe is an IR probe and is not used for homing any axes
    G31 X16.15 Y4.91 Z0.20 P500 ; Set the zprobe height and threshold (put your own values here)

    ;*** If you are using axis compensation, put the figures in the following command
    M556 S78 X0 Y0 Z0 ; Axis compensation here

    M208 S1 Z-0.2 ; set minimum Z
    ;
    T0 ; select first hot end



  • Have you tried removing the IR sensor?



  • Yes, It didn't help at all. Same symptoms.


  • administrators

    Very strange. Is there any visible sign of damage to the X and Y stepper driver chips?

    Not homing all the way on a delta typically means that you don't have the XYZ parameters set high enough for your printer in the first G1 S1 command in homedelta.g.



  • XYZ parameters are fine, it homed perfectly up until this all started.

    I just checked, the board looks perfect. Clean and new.



  • New finding, X and Z motors work, if Y is not connected.
    But, Y only works if it is the only motor connected. The minute I connect another motor, then Y stops working. If I connect all 3 motors then Z works, X stutters and doesn't move and Y doesn't work at all.

    Lastly, I changed the connectors on the Y motor to the spring loaded pluggable terminal block(http://www.mouser.com/ProductDetail/Phoenix-Contact/1778858/?qs=sGAEpiMZZMsDddcp1dBDJKhPf8Wt%2FPoGWIxxRhPLrJ8%3D) I got from tricklaser, - still same problems.

    One more thing - with power on, there are red leds lighted on the X and Z motors, but no led on the Y.

    I suspect a hardware problem. This is a brand new board purchased from Filastruder, first time setting up. Is it possible to exchange it?


  • administrators

    It sounds like a power problem to me. Check that the screws in the VIN terminal block are tight, also the screw terminals on the power supply.



  • You may be onto something. I had checked the screws were tight, but I do have two V- lines going into the board. I removed the Bed V- and tightened the screw on the single V- and all motors worked and homed properly. But, of course, now I have no heated bed. I'll try putting both V- wires into one of the ferrules and see if that fixes the problem all together.

    Btw: the red leds by the motor connections mean - endstops on/off?



  • Okay - it is probably a power problem - but it is also a board problem. The power supply terminal block is loose. It wiggles when I try to screw anything into it, or when I touch it with a finger. And by wiggles, I mean twists from side to side when I try to turn the screw.
    The Y motor connector block is also loose, which might explain why the Y motor has the most problems.

    If I turn over the board, the solder pads look okay, but I wonder if there is a broken connection.


  • administrators

    I am not convinced it is a board problem if the problem goes away when the bed heater PSU is disconnected. It's not uncommon for the terminal blocks to feel slightly loose, this is ok as long as they are soldered securely. When tightening the terminal block screws, I hold the terminal block.

    Can you explain in what way the Y motor connector is loose?

    The endstop LEDs are on when the endstop inputs are connected to ground. Whether this is when the endstops are triggered or not triggered depends on what type of endstop switch you use.



  • Additional issues, My extruder motor doesn't work either. It heats up and is tuned okay, but it doesn't turn at all when I click extrude while hot, or when it is cold, and I send M302 P1 for cold extrusion and then G1 E10 F300. Zilch, Nada, Nothing. Like I did with the Y connector, I switched from the supplied connectors to a spring-loaded one to insure a good connection.
    My E0 motor is a 2.4v 1.0A Kysan geared stepper.

    So, I was able to get X,Y&Z to work if after some fiddling with the Power supply terminal block. By fiddling I mean after tightening the wires all the way down - I moved it back and forth (right and left) with a screwdriver and things started working.

    But, then I discovered that E0 didn't work at all. More Importantly, E0 does not work if the heated bed power supply is disconnected and only the main one is connected.

    The wires in from the power supply are connected as tightly as possible to the terminal block. At the screw points I measure 12.37v. Which is exactly what I measure on the power supply itself.

    I'm very frustrated. I even installed 1.17RC3 to see if it would help.

    I know the motors work properly, and the wires and connectors are fine, because I tested with an LED per coil pairs.

    The Y connector points have slightly more movement up and down than the X and Z points. But, that said, the E0 connector points are firmly attached and E0 isn't working, so the Y connector almost certainly isn't an issue. And, as I said earlier - if I look at the back of the board, all the solder pads look just fine.

    As for the end stops, I was just asking because I wasn't sure what all the LEDs do. Should there be an LED for E0? If so, under what circumstances would it light up? Because I've never seen anything light.


  • administrators

    Hi sandy,

    I still don't understand how the pins on the Y motor connector can be loose unless they are not soldered on the underside of the board.

    The firmware will only drive an extruder motor if that drive is assigned to a tool, and the tool is selected, and either it is at a high enough temperature or you have turned off cold extrusion prevention.

    Yes there is an led for the E0 endstop input, and like the others it illuminated when it is pulled down to 0V.



  • Yes, I know. See the above posts. I also know about the cold extrusion prevention.
    As I said in the previous entry - I don't consider the Y connector a problem. So please ignore it.

    Right, as stated above, I tested this both with the hot end heated up and selected and with the cold extrusion prevention disabled.
    First, I tried with the tool selected - heating first to 190 and then trying to extrude 10, 25, etc – no response. Heating to 220 and trying to extrude 10, 25, etc. No response.

    Second,
    I disabled cold extrusion prevention (see above comments about the M302 P1 command) and tried extrusion - no response.

    with a 12v power supply measuring 12.3 v in at the V+ V- terminals - I get the following:

    Pin 1 on the Z motor connection point: 6.4v,
    Pin 1 on the Y motor connection point: 6.1v,
    Pin 1 on the X motor connection point: 5.4v
    Pin 1 on E0 motor connection point: 6.1v
    Pin 1 on the E1 motor connection point: 6.8v - I tested this for reference only, I don't have E1 tool defined.

    To V+ on the E0 heater: 12.3

    Look, these are the same motors and power supplies and everything that was working before I switched to the duet-wifi. The X,Y,Z motors are Wantai 42Byghw811 - 2.5A and the E motor is a Kysan 2.4v 1.0A Kysan I know the connectors are fine - put an LED across each of the paired coils of every motor and spun it - to make sure they were properly connected.

    I've spent 4-7 hours per day since the 23rd trying things, testing, searching for answers on the web. (I get a bit obsessed when a puzzle should be solvable and isn't)

    I've even tried raising the Voltage coming in from the power supply up to 15V -- ( I didn't try to heat it up - I have a 40v/12 cartridge and I didn't want to risk a melt down, so I just did the cold extrusion test.)

    I don't know what else to try. If you think that I am not supplying sufficient power, I'm not sure how to calculate my power requirements for the extruder motor, because I don't know what it's hubbed gear count is, but the Kysan motors are supposed to have lower power requirements than the Wantais and everything worked before.
    I do have a 24v power supply I could switch in, but what would that do to my hot end?



  • I forgot to say that those measurements were taken several times, with the power turned on, but not connected to the wifi. These measurements are consistent, not averages. Why such a major difference between X and all the others?


  • administrators

    Looking at your config.g file I see that you have only one extruder drive configured on tool 0 yet you have mixing enabled. Try it without enabling mixing.

    If you suspect a problem with the E0 motor driver, you could move the motor to E1 (with power off of course) and adjust your M563 command accordingly.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.