Duet Wifi strange error : Heater fault



  • I have a Duet wifi, i print PLA at 230 ° after a few minutes of printing show me this error: "Canceled printing file test.gcode, print time was 0h 9m
    Error: Shutting down two to one-cleared heater fault after 600 seconds "
    I did ghost print without PLA filament with temperature 0° gives me the following error:
    "Warning: Tool 1 was not heated because it has a heater fault" but completes printing.
    I did another phantom print test with the 230° temperature without pla filament and completed it.
    Is it possible that the pla filament with a 0.8 nozzle can give problems to the temperatures?



  • I have done another test!
    With my gcode at 230° i have set manually the duet at 245, i hope that the more gap by the machine and gcode help the tollerance of heater fault. But no!!! The machine Stop after 2 minute of work. But if i use the same file and not load the filament, this problem disappear



  • @blulaserstar Just guessing here: it might be that with your rather large nozzle the heater cannot keep up against the "cold" filament. Have you tried reducing print speed? This would also reduce the amount of plastic pushed into the hotend in the same amount of time and would therefore have a lower cooling effect.



  • Have you PID Tuned the heater as well?


  • administrators

    1. Run PID tuning on the heater, if you haven't already.

    2. 10 minutes before the heater shuts down, it should pause the print with a message about the heater fault. Did it do that, and if so what was the heater fault message?



  • OK i have try to do this:
    nozzle diameter: 0,80
    extrusion multiplier: before was 1 now 0,80
    Extrusion with: before was 0,96 now 0,90
    First layer speed: before was 80% now 65%
    Speed: i have tryed 30mms, 40mms, 50mms.

    But always at 0:9 minuts the error jump!!!

    For the PID, i have controlled this parameters on config:

    ; Heaters;
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S280 ; Set temperature limit for heater 2 to 280C

    Alway always stop at 0.9minut



  • @blulaserstar said in Duet Wifi strange error : Heater fault:

    For the PID, i have controlled this parameters on config:

    ; Heaters;
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S280 ; Set temperature limit for heater 2 to 280C

    There are no PID tuned values in there. They would start with M307. Did you perform M303: Run heater tuning?



  • No i didn't perform m303 run heater tuning, i'm try to understand the guide that you have link to me. Really thanks



  • ok i have tryed to do but, is not easy 😉 now when io check the tune:

    M303
    Heater 1 tuning failed

    Grrrrrr i hope to do 😞


  • administrators

    @blulaserstar said in Duet Wifi strange error : Heater fault:

    M303
    Heater 1 tuning failed

    Is that all? It usually says why it failed.



  • alt text

    but i'm not sure that i have done the right things:

    alt text



  • M303 on it's own simply reports the status of the last heater tune. To tune the heater you need to specify which heater, the PWM valuer to use (usually 1.0 which is the default) and the target temperature. So use something like M303 H1 S270. Once the tuning has completed successfully, you need to use M307 to add the A, C and D paramters into you configuration file, either use M500 to put them into config.overide.g or enter the values directly into config.g. See here https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control


  • Moderator

    You need to send those M303 commands from the console, not in config.g. It will go through a PWM tuning routine and will result in values appropriate for your heater to maintain your requested temperature. Those values will then go into your config, either by manually entering them into config.g or by saving them with M500 so they automatically go into config-override.g Doing it that way will require M501 at the end of config.g to load the values from config-override.g

    https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control#Section_Setting_the_model_parameters_by_auto_tuning



  • ok really really thanks for your help. i have done the auto tune only the first one don't show me error the other: alt text
    alt text
    but i have done the M307 H2 and show: alt text So i have do M500 and on config i have write:
    M307 H2 A537.6 C202.5 D5.9 B0

    But now i have a problem: when i select my tool and i do: G10 P1 S230 nothing is happen!!! I have try to delete the row M307 H2 A537.6 C202.5 D5.9 B0 on my config but no more heate the nozzle!



  • update i have tryed to set 170 as active or standbye temperature, and it work, so I set 180, 190...220 and it work but if i write 230, the H2 go off 😮


  • administrators

    @blulaserstar said in Duet Wifi strange error : Heater fault:

    update i have tryed to set 170 as active or standbye temperature, and it work, so I set 180, 190...220 and it work but if i write 230, the H2 go off 😮

    What exactly happens when you try to set 230C: does it start heating but then give you a heating fault? Or does it refuse to heat at all? If it refuses to heat at all, check your M143 H2 temperature limit setting.



  • you are right, i'm sorry, i haven't see that the m143 h2 was 230!
    But nothing the printer stop at 9 minuts!!!

    I have tryed to do auto tuning at 270° and save with m500 but at 9 minuts stop:
    Cancelled printing file sgianpolrotato.gcode, print time was 0h 9m
    Error: Shutting down due to un-cleared heater fault after 600 seconds

    now i don't really know what can i do!


  • administrators

    Do you have a M501 command near the end of config.g, so that it runs config-override.g which is where M500 stores the heater tuning results?



  • yes I have it and keeps giving the same error after 9 minutes

    alt text
    alt text


  • administrators

    Might you be getting a heater fault right at the start of the print? I suggest you start a print and then look very carefully at status of all heaters reported by DWC.



  • i have look verry verry carefully the DWC here is a screen video me i don't see nothing of strange
    Screen capture video



  • @blulaserstar in that video it clearly shows that you have heater faults on Tool0 and the Bed heater they both read 2000C which is normally a open circuit thermistor on those heater you need to either disable them or correct them I bet you are actually getting the print stop at 9:59 secs.



  • @Dougal1957 nooooooo you aren't say me that the bed heater disconnect make this error????

    I don't believe! How do you suggest to disable? by comment the firmware, on config.g?



  • @blulaserstar you can comment out the lines in Config.g but the best way is to fix the thermistors on both the bed and the Tool ) as they are both in error.

    0_1534933479275_bdcfbb38-59e0-4547-a6d3-d739e7599fd4-image.png



  • @dougal1957 i know, but for the moment and for the future i don't want to use the bed and the second extruder! so i prefer to disable a moment in the firmware. On december i think that i'll try to activate the bed and the second extruder.


Log in to reply