Problem connecting to printer with printer_name.local



  • I have an odd problem. I can only connect to my duet wifi with one of the 9 devices I have tried. I want to use a tablet or mobile to control my printer, but the only device that will connect is 1 computer which is 2 floors away from the machine! I have tried 3 PC´s, 3 tablets and 3 mobiles (android). My machine is named "BFP9000" and when I try to connect usung "BFP9000.local" (just that not with www etc) I get "could not connect to http://www.BFP9000.local"
    Only 1 browser on one computer will connect and it happens to be 2 floors away from the printer so hardly practical! The other browsers on all other machines add www. etc in front of the name and fail to connect.
    Anyone know a work around? yes its the latest firmware and I have tried 3 or 4 different browsers on 9 devices. As the ip address is dynamically set I cant connect via ip address without lots of hassle. I am guessing there is some browser setting but I have searched and not found any help anywhere!



  • @splathammer said in Problem connecting to printer with printer_name.local:

    I have an odd problem. I can only connect to my duet wifi with one of the 9 devices I have tried. I want to use a tablet or mobile to control my printer, but the only device that will connect is 1 computer which is 2 floors away from the machine! I have tried 3 PC´s, 3 tablets and 3 mobiles (android). My machine is named "BFP9000" and when I try to connect usung "BFP9000.local" (just that not with www etc) I get "could not connect to http://www.BFP9000.local"
    Only 1 browser on one computer will connect and it happens to be 2 floors away from the printer so hardly practical! The other browsers on all other machines add www. etc in front of the name and fail to connect.
    Anyone know a work around? yes its the latest firmware and I have tried 3 or 4 different browsers on 9 devices. As the ip address is dynamically set I cant connect via ip address without lots of hassle. I am guessing there is some browser setting but I have searched and not found any help anywhere!

    You do not say what systems you are using. The .local MDNS scheme is not supported by Android (or at least hasn't been in the past) and is not a standard part of Windows (or at least hasn't been in the past). It is normally available on Linux and Macs. I believe that it can be available on WIndows if you install iTunes? Hope this helps.

    PS - I have only Linux machines here and MDNS on the Duet has worked but tends not to be totally reliable so I have reverted to giving the Duets fixed IP addresses.



  • I should add that I use the .local scheme all the time here totally reliably between (ink) printers and other computers but not with the Duets.



  • @burtoogle said in Problem connecting to printer with printer_name.local:

    I believe that it can be available on WIndows if you install iTunes?

    I think you only need the Bonjour package from iTunes, not the whole thing. Apple have made this harder than necessary to install standalone, but it's still possible:

    http://www.flamingpc.com/2017/01/25/how-to-install-latest-bonjour-version-3-for-windows-without-installing-itunes/

    adavidm



  • I have used Windows 10 (3 computers) and android 6 and 7 on mobile devices. Sorry I dont do apple stuff (pet hate!). I have tried Firefox, windows explorer and google chrome on pc and cm browser and lots of other browsers on android. It works on one PC with windows 10 but not on anything else. there must be some obscure setting that for some reason is enabled on that 1 install. can I set a permanent ip address on the duet and just use that to log in from other devices?



  • sorry, should have added works on win 10 and firefox BUT sometimes I still get the attempt to add https://www. etc so I have to go from a bookmark.


  • administrators

    @splathammer yes you can set a permanent IP address and then connect directly to the IP address. One way to do this is to add a DHCP reservation for the Duet on your router so it always gets the same address.



  • T3P3Tony
    Thanks, but how exactly do I do that?



  • T3P3Tony
    Sorry should have added - how to do it on the duet and router.


  • administrators

    @splathammer (edited for clarity)

    Option 1 - DHCP reservation
    How to do this depends on the router, most of the "standard home routers" (if there is such a thing) have a configuration page on the local network that allows you to see what devices are connected and their MAC address, then you can reserve an IP address for that MAC address. No changes are required to the Duet.

    Option 2 - Assign a fixed IP to the Duet
    You don't have to do that, you can just give the Duet a fixed IP address:
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M587_Add_WiFi_host_network_to_remembered_list_or_list_remembered_networks
    but you should select that address from the same local network as the rest of your devices are getting from the router, but outside the DHCP range so that you don't get an IP address conflict. No changes are required to the router, but you may need to login to the router to find out what range it is using for DHCP so that you can select an address outside that range but still in the local network.



  • I had the same issue earlier and fixed it by following the steps a little bit later.

    The .local top level domain (tld) is meant as a configuration-less name resolution (also known as mDNS) and simply works by Windows (or for that matter any supported operating system) asking as a broadcast (special network package that is sent to all devices on the network) if any device knows the IP address of the name it needs to find. Either the correct device will respond, or if any other device found the correct one, they may also respond.

    To follow the steps below, you might need Administrator access. Always be careful when entering commands that are not obvious in what they will do. Don't simply follow a guide like this blindly (in this case, each setting have a full description, make sure you understand what it does).

    In Windows 10, it is supported and named "Link‐Local Multicast Name Resolution" and here is how to enable/disable it:

    1. Using the Run Box (Windows + R; Right-click on start and select Run), type "gpedit.msc" and Run it - this is the Local Group Policy Editor.
    2. Using the left hand navigation go to: Computer Configuration > Administrative Templates > Network > DNS Client
    3. Inside this list of settings we have a few values that we are interested in: "Prefer link local responses over DNS when received over a network with higher precedence", "Turn off multicast name resolution"
    4. The "Prefer link local responses..." can be set to Enabled.
    5. The "Turn off multicast name resolution" should be set to Disabled.
    6. Flush the DNS Cache: using Command Prompt or Power Shell (may need Administrator access) send the command:
      ipconfig /flushdns

    In my case, to resolve the issue, I first had to Enable the option in nr 5 (which actually disables it), then restart and finally Disable it again and the flush the DNS cache. It appeared that other software might have interfered with this setting initially.


  • administrators

    Thanks for that, I didn't realise that recent versions of Windows no longer need Bonjour service installed to support mDNS.



  • @jacotheron Hi

    Sorry for the delay in getting back to you. Unfortunately this is only available on pro and corp versions, not on home.
    Its easier to just go the fixed ip route. But as it turns out it doesnt matter as I am taking the board out and selling it. I have had serious problems with the board doing random stuff and it just rammed the hotend into the bed and damaged the printer again for the third or forth time and I have had enough - too many bugs.



  • @t3p3tony Hi

    Sorry for the delay in getting back to you. I sorted it out and as a bonus it stopped disconnecting every few minutes.
    But as it turns out it doesnt matter as I am taking the board out and selling it. I have had serious problems with the board doing random stuff and it just rammed the hotend into the bed and damaged the printer again for the third or forth time and I have had enough - too many bugs. It was printing the first layer of a 15cm x 25 cm box and when it finished one section and went to move to the other side it raised the bed and rammed the hotend into it then went to move gouging through the 0.6mm layer (volvano hot end with 0.8mm nozzle) all the way to the bed and wrecking the mount. This is not the first time it has done something like this (its the third or forth) and I have hardly used the machine at all. it also has a habit of changing the 0 height by 4 or 5 mms, so it will be perfectly set up and print several items no problem, then when I turn it on again its completely off by several mms. The machine is industrial grade with highwin and CPC linear rails, 8mm machined bed and 1500 watt AC bed heater and cost a lot of money to build. It is vital to developing my business and I now have absolutely 0 confidence in the controller, actually less than zero as I know it is 100% likely to bugger up at any time. The machine is intended to run every day and I cant afford to have it self destruct every few days. Nice hardware and interface but the software is buggy as hell. I have been 3D printing for about 18 months and have never had a problem with my RAMPS board based printer.

    I would like to hear your thoughts on this, maybe its my fault but I really really doubt it.



  • @burtoogle Hi
    Sorry for the delay in replying. Yes I found the .local meant it disconnected at short random intervals. I change to fixed ip and it connects fine, but as I have put in my reply below to T3P3Tony i am selling the board due to its habit of randomly ramming the hotend into the bed and trashing it and also suddenly changing the offset by 3 - 5mm at random intervals when switched off and on. Its way to buggy for me to use it for anything important.


Log in to reply