Disconnected when M291



  • Hi,

    I use M291 on each print start to add hair spray on my glass. Each time the web interface lost connection (but I can reconnect). Am I missing something?

    My gcode is :
    M291 P"Ok pour continuer" R"Mettre la laque" S3 ; Pause


  • administrators

    What firmware and DWC versions are you using?



  • I'm using
    Firmware 2.01beta2
    WiFi Server 1.21
    Web Interface 1.21.2-b2



  • I've got this error
    0_1535133429170_disconnected.JPG


  • administrators

    @jul please try a later version of DWC, may as well upgrade to Firmware 2.01 (not the beta) at the same time.

    https://github.com/dc42/RepRapFirmware/releases/tag/2.01



  • As DWC reconnects automaticaly, it seems to solve my problem.
    Thx


  • administrators

    @jul said in Disconnected when M291:

    As DWC reconnects automaticaly, it seems to solve my problem.
    Thx

    Did you upgrade both the firmware and DWC to non-beta versions? AFAIR that issue was caused by a bug in the beta, so if you upgraded both then you should not be getting those disconnections any more.



  • I upgraded both


  • administrators

    1. Please confirm all the version numbers, as shown on the Settings->General page of DWC if it gets that far.

    2. Do you get that error no matter what DWC page you try to access, or just on some pages?



  • 1.0_1535472645856_2.01.JPG

    1. No matter on wich page I am

  • administrators

    In that case, it looks like a configuration-dependent firmware bug and what I ideally need is a Wireshark trace (the .pcap file) of a connection attempt. If you find that too difficult, then if you post your config.g file I can try to reproduce it.



  • I've got a .pcap file for you. Unfortunetly is to big to upload. Can you give me your mail address for it (or an altenative)?

    Wait, I think i've just find what's wrong. There was an error in the config.g . SSID name was different between M587 and M552
    I'll try after my print and tell you

    This is my config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Aug 06 2018 16:00:33 GMT+0200

    ; General preferences
    M501 ; read config
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PMy printer ; Set machine name
    M587 S"wifiAThomr" P"************************* ; Configure access point. You can delete this line once connected
    M552 S1 P"wifiAThome" ; Enable network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X100 Y100 Z400 E95.73 ; Set steps per mm
    M566 X900 Y900 Z100 E200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z1800 E4500 ; Set maximum speeds (mm/min)
    M201 X600 Y600 Z150 E300 ; Set accelerations (mm/s^2)
    M906 X2400 Y2400 Z2000 E2000 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S180 ; Set idle timeout

    ; Pressure Advance
    M572 D0 S0.05

    ; Axis Limits
    M208 X-50 Y-36 Z0 S1 ; Set axis minima
    M208 X220 Y220 Z280 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P1 H5 F120 T9600 B1 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X32 Y5 Z2.30 ; Set Z probe trigger value, offset and trigger height
    M557 X20:200 Y20:200 S90 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S90 ; Set temperature limit for heater 0 to 90C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S270 ; Set temperature limit for heater 1 to 270C

    ; Fans
    M106 P0 S0.0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0.8 I0 F500 H-1 ; extruder fan
    M106 P2 S0.7 I0 F500 H-1 ; board fan

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured


  • administrators

    Please put the .pcap file on Dropbox or another file sharing site and post the link to it here. Alternatively, look for the http 200 OK response where Wireshark reports that the response format is JSON but instead of letting you expand the json object is reports "Line based text data". That will be the faulty response. So right click on that, select copy as text to get the full data, and paste that here.

    Having a different SSID name in M552 and M587 should just result in failure to connect to your router. The SSID is not passed to DWC so I don't think that is triggering the problem.

    btw the M307 command in config.g will override any M307 command for the same heater in config-override.g that was obtained from turning the heater. We normally put the M501 command near the end of config,g so that it overrides values in config.g as the name suggests.



  • Let me know if this is what you want:

    [truncated]{"status":"P","coords":{"axesHomed":[1,1,1],"xyz":[-50.000,220.000,10.000],"machine":[-50.000,220.000,10.000],"extr":[0.0]},"speeds":{"requested":0.0,"top":0.0},"currentTool":0,"output":{"beepDuration":10,"beepFrequency":50"ms


  • administrators

    @jul, that's the truncated version, which is too short. If you right click on it you should get a number of options including "Copy... Bytes as printable text". Choose that one, then paste it in your post.



  • Like this?

    {"status":"P","coords":{"axesHomed":[1,1,1],"xyz":[-50.000,220.000,10.000],"machine":[-50.000,220.000,10.000],"extr":[0.0]},"speeds":{"requested":0.0,"top":0.0},"currentTool":0,"output":{"beepDuration":10,"beepFrequency":50"msgBox":{"msg":"Ok pour continuer","title":"Mettre la laque","mode":3,"seq":2,"timeout":0.0,"controls":0}},"params":{"atxPower":0,"fanPercent":[0,80,70,0,0,0,0,0,0],"speedFactor":100.0,"extrFactors":[100.0],"babystep":0.000},"seq":14,"sensors":{"probeValue":37,"fanRPM":0},"temps":{"bed":{"current":49.4,"active":60.0,"state":2,"heater":0},"current":[49.4,38.1,2000.0,2000.0,2000.0,2000.0,2000.0,2000.0],"state":[2,2,0,0,0,0,0,0],"tools":{"active":[[0.0]],"standby":[[0.0]]},"extra":[{"name":"MCU","temp":31.9}]},"time":7022.0,"currentLayer":0,"currentLayerTime":0.0,"extrRaw":[0.0],"fractionPrinted":0.1,"filePosition":6834,"firstLayerDuration":0.0,"firstLayerHeight":0.20,"printDuration":147.8,"warmUpDuration":82.4,"timesLeft":{"file":43658.1,"filament":0.0,"layer":0.0}}


  • administrators

    @jul said in Disconnected when M291:

    {"status":"P","coords":{"axesHomed":[1,1,1],"xyz":[-50.000,220.000,10.000],"machine":[-50.000,220.000,10.000],"extr":[0.0]},"speeds":{"requested":0.0,"top":0.0},"currentTool":0,"output":{"beepDuration":10,"beepFrequency":50"msgBox":{"msg":"Ok pour continuer","title":"Mettre la laque","mode":3,"seq":2,"timeout":0.0,"controls":0}},"params":{"atxPower":0,"fanPercent":[0,80,70,0,0,0,0,0,0],"speedFactor":100.0,"extrFactors":[100.0],"babystep":0.000},"seq":14,"sensors":{"probeValue":37,"fanRPM":0},"temps":{"bed":{"current":49.4,"active":60.0,"state":2,"heater":0},"current":[49.4,38.1,2000.0,2000.0,2000.0,2000.0,2000.0,2000.0],"state":[2,2,0,0,0,0,0,0],"tools":{"active":[[0.0]],"standby":[[0.0]]},"extra":[{"name":"MCU","temp":31.9}]},"time":7022.0,"currentLayer":0,"currentLayerTime":0.0,"extrRaw":[0.0],"fractionPrinted":0.1,"filePosition":6834,"firstLayerDuration":0.0,"firstLayerHeight":0.20,"printDuration":147.8,"warmUpDuration":82.4,"timesLeft":{"file":43658.1,"filament":0.0,"layer":0.0}}

    In theory that's what I need, however there is no error at column 188 in that line. So either:

    1. The line you copied isn't the one with the error. Did it say "Line based text data" or similar?

    2. The error no longer occurs at column 188. Did you upgrade the firmware? if so the column number may have changed. Please check the DWC error message again.

    EDIT: I just spotted an error at column 224. Investigating.



    1. Yes it say "Line based...". I have another but just with '/n /n' so i didn't think was relevant.
    2. I didn't upgrade since T3P3Tony ask to go with non Beta version. Also, I don't have any error message since this upgrade, I can just see there is deconnection on the gcode console

  • administrators

    Please can you test whether the new firmware binary at https://www.dropbox.com/s/fyvibzm0zl92hiy/Duet2CombinedFirmware.bin?dl=0 solves the problem. Caution: this is a beta, so babysit it.



  • I'll try it ASAP, I hope Sunday


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.