JavaScript errors when executing commands in the G-Code-Console



  • Recently I am not able to send commands from the G-Code-Console. Or actually I can, but then I always get this error message:
    0_1535387645451_Bildschirmfoto 2018-08-27 um 17.59.36.png
    I tried some different G-Codes --> all end in a crash.

    I think it is because of the new MacOS Mojave Beta 10.14 update. It wasn't before.

    Firmware Version: 2.01(RTOS) (2018-07-26b2)
    WiFi Server Version: 1.21
    Web Interface Version: 1.22

    Safari Browser
    Java 8-Update 161



  • you could try updating to the latest DWC 1.22.2 which was released earlier today I believe it has a fix for that particular issue.

    DWC 1.22.2



  • Thanks, it works now.

    Didn't even know there is a newer DWC version.
    The hole Github system is too strange for me.
    Different websites for stable version releases, beta versions, DWC and firmware. Also downloads and release notes are separated.
    And there isn't an info (in DWC) if there is an update available. If you aren't very forum active, you will never know if there are newer versions.

    That should be a lot easier!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.