Always misaligned after 3 point probing (3 stepper)



  • Hi! -

    So im building a D-bot with a custom Z-axis -

    The Z axis uses 3 independent steppers and the DC42 IR probe. - But after running the G32, the X-axis is alway tilted a bit -
    ![Bed picture](0_1535554029844_7903e293-9160-472e-90b4-a927fc226649-image.png image url)
    What can cause this?
    My config file looks like:

    M586 P0 S1                                                             ; Enable HTTP
    M586 P1 S0                                                             ; Disable FTP
    M586 P2 S0                                                             ; Disable Telnet
    
    ; Drives
    M569 P0 S1                                                             ; Drive 0 goes forwards
    M569 P1 S0                                                             ; Drive 1 goes backwards
    M569 P2 S1                                                             ; Drive 2 goes forwards
    M569 P3 S1                                                             ; Drive 3 goes forwards
    M569 P4 S1 C65972                                                           ; Drive 4 goes forwards
    M569 P5 S1                                                             ; Drive 5 goes forwards
    M569 P6 S1                                                             ; Drive 6 goes forwards
    M569 P7 S1                                                             ; Drive 7 goes forwards
    M569 P8 S1                                                             ; Drive 8 goes forwards
    M569 P9 S1 C65972                                               ; Drive 9 goes forwards
    
    M584 X4 Y9 Z0:1:2 E6:7                                                     ; Apply custom drive mapping
    M350 X16 Y16 Z16 E16:16 I1 S2                                            ; Configure microstepping with interpolation
    M92 X200 Y200 Z800 E415:415                                           ; Set steps per mm
    M566 X1500 Y1500 Z18 E300:300                                          ; Set maximum instantaneous speed changes (mm/min)
    M203 X8400 Y8400 Z800 E2400:2400                                       ; Set maximum speeds (mm/min)
    M201 X500 Y300 Z250 E250:250                                           ; Set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1000 E1500:1500 I40                                  ; Set motor currents (mA) and motor idle factor in percent
    M84 S10                                                               ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                                                       ; Set axis minima
    M208 X320 Y290 Z500 S0                                                 ; Set axis maxima
    
    
    
    
    ; Define the X and Y coordinates of the leadscrews.
    ; Must come after M584 (Set drive mapping), M667 (Select CoreXY Mode) and M669 (Choosing Kinematics type)
    ; Motor order: Front right (1), front left (2), rear center (3).
    ; Snn Maximum correction in mm to apply to each leadscrew (optional, default 1.0)
    M671 X-50:385.0:385.0 Y170:35:310 S20 P2
    
    ; Endstops
    M574 X1 Y1 S3                                                          ; Set endstops controlled by motor load detection
    
    ; Z-Probe
    M574 Z1 S2                                                             ; Set endstops controlled by probe
    M558 P1 H5 F620 T6000                                                  ; Set Z probe type to modulated and the dive height + speeds
    G31 P500 X0 Y47 Z3                                                     ; Set Z probe trigger value, offset and trigger height
    M557 X20:320 Y50:280 S20                                               ; Define mesh grid
    
    ; Heaters
    M305 P0 T100 B4202 C4.387169e-7 R4700                                  ; Set thermistor + ADC parameters for heater 0
    M143 H0 S80                                                            ; Set temperature limit for heater 0 to 80C
    M305 P1 T100000 B4725 C7.060000e-8 R4700                               ; Set thermistor + ADC parameters for heater 1
    M143 H1 S360                                                           ; Set temperature limit for heater 1 to 360C
    M305 P2 T100000 B4725 C7.060000e-8 R4700                               ; Set thermistor + ADC parameters for heater 2
    M143 H2 S360                                                           ; Set temperature limit for heater 2 to 360C
    
    ; Fans
    M106 P0 S0.3 I0 F500 H-1                                               ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1:2 T45                                            ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1:2 T45                                            ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1                                                          ; Define tool 0
    G10 P0 X0 Y0 Z0                                                        ; Set tool 0 axis offsets
    G10 P0 R0 S0   
                                                            ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H                                                           ; Define tool 1
    G10 P1 X18 Y0 Z0                                                       ; Set tool 1 axis offsets
    G10 P1 R0 S0                                                           ; Set initial tool 1 active and standby temperatures to 0C
    
    ; Automatic saving after power loss is not enabled
    
    ; Custom settings are not configured
    
    ; Miscellaneous
    M501                                                                  ; Load saved parameters from non-volatile memory
    

    Home all

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Jul 31 2018 15:05:50 GMT+0200 (Centraleuropæisk sommertid)
    
    M400; make sure everything has stopped before we make changes
    M574 X1 Y1 S3		;		
    M913 X30 Y30 		; XY motors to 30% current	
    M915 X Y H400 S3 R0 F0	; set X and Y to sensitivity , do nothing when stall, unfiltered
    
    
    ; X axis home		
    G91			; use relative positioning
    G1 Z5 F6000 S2    ; lift Z relative to current position
    G1 S1 X-405 F6000 ; move quickly to X axis endstop and stop there (first pass)
    G1 X5 F6000       ; go back a few mm
    G1 S1 X-405 F4000  ; move slowly to X axis endstop once more (second pass)
    
    ; Y axis home
    G1 S1 Y-305 F6000 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y5 F6000       ; go back a few mm
    G1 S1 Y-305 F4000  ; move slowly to Y axis endstop once more (second pass)
    G90               ; absolute positioning
    M913 X100 Y100; motor currents back to 100%
    
    ; Z-axis
    
    M561                     ; Clear any bed transform
    G32                      ; Start 3-point probe sequence - Bed.g
    G1 Z20.0 F6000           ; Move Z to 20
    G1 X5 Y5    		 ; Move Head to front left
    

    and my bed.g:

    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Jul 31 2018 15:05:50 GMT+0200 (Centraleuropæisk sommertid)
    M561 ; clear any bed transform
    M117 g28;
    G28 Z;
    G29 S2; Clear bed height map 
    ; Probe the bed at 3 points
    G30 P0 X0 Y160 Z-9999 ; Front Right
    G30 P1 X320 Y47 Z-9999 ; Front Left
    G30 P2 X320 Y280 Z-9999 S3 ; Center Rear
    

    It is always the same error where the right side (x+) is lower than the left side (x-)



  • First guess is that the order of your steppers on the board doesn't match the order you have them configured.

    M584 X4 Y9 Z0:1:2 E6:7 ; Apply custom drive mapping

    That order for the Z steppers needs to match the order here:

    M671 X-50:385.0:385.0 Y170:35:310 S20 P2

    If not, the corrections applied will be to the wrong leadscrew.



  • that helped a bit

    alt text

    Still a bit much noise it looks like - The bed should be pretty flat - It is an 6mm cast aluminium (similar to MIC6 ) and have a printsheet on top (chinese magnetic buildtak)



  • Is the buildtak sheet reflective?

    I suggest setting a sheet of paper on top of the bed and trying again.


  • administrators

    Yes, it looks like the IR sensor doesn't work well with that bed surface. What does the surface look like?



  • @dc42
    Right now it is a little bit blank - it is the magnetic part of one of those aliexpress magnetic print surface - Will try with the print surface on when i get back (the Matt print surface you print on the magnetic sheet)


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.