Slic3r PE and M900,M907 errors.



  • Running into issues trying to get dual extrusion to work on the Duet with the Slic3r Prusa Edition. Here is the error I am getting when I try to print using gcode sliced from the slicer.

    8:47:54 PMError: M900 command is not supported
    Error: M907 command is not supported

    This is the error I'm getting when I try to use Silc3r Prusa Edition. It will print with two extruders into a cyclops when Single Extruder Multi Material is disabled, but once it is enabled it stops after purging and gives me that error.
    The printer itself works with other slicers like S3D and Cura, but it's only when trying to run gcode from Slic3r PE with Single Extruder Multie Material enabled do I get the error messages and it stops.

    Anyone got a solution to this?

    Thank you



  • What gcode flavour is slicer PE set to use?



  • @phaedrux I have it set to RepRap/Sprinter



  • 1_1535921567935_Test Single Nozzle Enabled.gcode 0_1535921567934_Test Single Nozzle Disabled.gcode

    Here is the gcode generated. The file "Test Single Nozzle Enabled" has the Single Extruder Multi Material option enabled in Printer settings in Slicer PE. If you search through the gcode, you can see it has M900 and M907 commands in it. Both commands give errors and will cause the printer to stop.

    The other file has that option disabled but it only contains M900 command but it will give me an error and still print.



  • M900 command is located under filament settings, custom gcode. It is used to set linear advance factor. Delete it or comment it out.



  • @obeliks Doesn't seem like that code stops the print. Seems to be the M907 which causes the print to stop.



  • I just tested and sending M907 doesn't seem to do anything

    M907
    Warning: M907 command is not supported

    M907 is used in Marlin for setting motor current. (RepRap uses M906).

    It's still odd that those gcodes are coming up at all if you're set to reprap flavour.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.