homing and all the other things.



  • Before I begin, i have to say that, i just started 3d printing and don't have any indepth knowledge. I just know some gcodes related to printing and thats all.

    I was using duetwifi ver. 1.21 on my p3steel and was getting good at it. Then i updated it to 2.02beta1(RTOS) (2018-08-12b5) so now i cant home my axes. I am not using probe or anything, i am using switches, z switch is at the bottom of printer, x switch is on the left by the stepper and y switch is in front. When they are hit, their leds are on on duet. Moving x,y,z to + side they get farther to switches, so i think they are moving correctly.

    I am using reprap configurator for settings, i chosed cartesian printer and reprap firmware. My files are as follows,
    4_1536255658140_homez.g
    3_1536255658139_homey.g
    2_1536255658138_homex.g
    1_1536255658138_homeall.g
    0_1536255658137_config.g

    can you help ?



  • It looks like you don't have a z endstop defined

    ; Endstops
    M574 X1 Y1 S1                    ; Set active high endstops
    
    ; Z-Probe
    M558 P0 H5 F120 T6000            ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:185 Y15:185 S20         ; Define mesh grid
    

    Did you generate a new config set when you upgraded to 2.02?



  • @phaedrux yes, this is new config set. I didn't save the old set.



  • Try M574 X1 Y1 Z1 S1 ; Set active high endstops to add the Z endstop.

    When you try to home all, what exactly happens?



  • @phaedrux i changed all a bit in

    config;
    ; Endstops
    M574 X1 Y1 Z1 S2 ; Set active high endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:185 Y15:185 S20 ; Define mesh grid

    homeall;

    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-205 Y-205 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F6000 ; go back a few mm
    G1 S1 X-205 Y-205 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G1 S1 Z-205 F1800 ; move Z up stopping at the endstop
    G90 ; absolute positioning
    G92 Z0 ; set Z to axis minimum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    before, z was lifting a bit, x and y were going to switches side a bit and were just stopping before touching switches or anyting. now with this homeall, they go all the way to switches, dont stop and keep ramming them. then i get afraid and push emergency stop 🙂



  • You switched M574 from S1 to S2. S2 is for using a z probe. Do you have active high switched, or active low switches?

    https://duet3d.dozuki.com/Wiki/GCode#Section_M574_Set_endstop_configuration

    Here is a safe way to test your endstops before you try and move any axis.

    https://duet3d.dozuki.com/Wiki/Connecting_endstop_switches

    https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Homing_files

    When you click the endstop switch with your finger does the light on the Duet go off or turn on? In the DWC machine properties tab does the endstop show as triggered?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.