Dual Z axis.



  • Anet A8 Z axis.
    Lots of trail and error.
    But before i can continue i need to figure out why my Z axis wont move properly, when i move the Z axis (I have 2 and both in the dual Z axis pins.
    There movement is weird, it sort of moves one then the other.

    I assume i am just missing something but cant figure out what it is.
    I have checked forum and google. but have come up nothing.



  • @latexcupcake Probably the your horizontal axis is not perpendicular to the z axis, and the two z axis are not parallel to each other. Then one side will move, something will flex, then the other axis moves. You should take an exact craftman's angle and check the angles



  • I thought that to. but checked and rechecked. re leveled X beam. and still seems to do it. it kind of moves in a pendulum fashion. it worked with the anet motherboard.



  • I had this problem as well, i'm not really sure how I fixed it but I know it had something to do with the drive settings in your firmware.



  • i am running through all options again. re leveled. checked angles. looking through config.g
    See thats what i was thinking to.
    but cant figure out what.
    are you still using the same config file?



  • @latexcupcake You can try to set one side a bit higher or lower by turning one of the Z axis by hand and test movement again. It may not be exactly calibrated. I would turn it a bit and count the turns, so you can turn back after the test.

    Another possibility is that the horizontal axis puts a force against your two z axes, so you should change this distance. You can find out by testing by hand whether the two z-axes are very stiff or not in horizontal direction.

    Another possibility is that the ball bushings of the z axis is moving stiff. This may be due to dust in the cage. You should disassable, clean and oil it then.



  • @joergs5 Appreciated i have tried this but all help is welcome.

    Both axis when not powered move fine and free.



  • @latexcupcake If no tip helps, you can make a short video and show us, this may give a hint what's the reason.



  • This is my config:

    ; Drives
    M569 P0 S1                                 	; Drive 0 goes forwards
    M569 P1 S1                                 	; Drive 1 goes forwards
    M569 P2 S0                                 	; Drive 2 goes backwards
    M569 P3 S1                                 	; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1                    	; Configure microstepping with interpolation
    M92 X100 Y100 Z1600 E95                		; Set steps per mm 
    M566 X1200 Y1200 Z4.5 E300                 	; Set maximum instantaneous speed changes (mm/min)
    M203 X24000 Y24000 Z120 E3000              	; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z100 E5000               	; Set accelerations (mm/s^2)
    M204 P400 T400                            	; Lower accelerations when printing though
    M906 X750 Y750 Z750 E750                   	; Set motor currents (mA)
    M84 S0                                     	; Disable motor idle current reduction
    

    I am having some struggles with under extrusion on my Anet A8 so I wouldn't copy the E values.
    I also changed my leadscrews to some with a lower leadscrew pitch, so the steps per mm for the standard rods should be 400.



  • Ahaha. it was the z steps. it was set to 4000. (done through RRF) changed it to 1600 and works properly now. i knew it was something simple but just couldnt see it. ((yeah mine had a 2020 x axis now, im going to be making it into a hypercube at some point.) looking at bearing lead screws for the z axis maybe.)

    Thank you both for all your help.



  • Glad I could help 🙂



  • @latexcupcake said in Dual Z axis.:

    Ahaha. it was the z steps. it was set to 4000. (done through RRF) changed it to 1600 and works properly now.

    Just to confirm this: did you also change your lead screw? Because as @MrNiceguy pointed out the stock Anet A8 has 400 steps/mm. It still might run with 1600 steps/mm but the positions would be way off in this case.



  • @latexcupcake Nice that you have a solution now and can print now.

    If you want to optimize in the future, you can consider using only one stepper and connecting the Z axes with a belt. Then a calibrated horizontal X axis will stay horizontal. Using two steppers, there can occur desynchronization after you turned off the printer.

    Just for completeness of my comment: I read that the trapezoid spindles have tolerances, so a 8x2 is not exactly 2 mm. To have two identical spindles, I read one can buy one large one (600 mm)and cut it in half. Then you have two identical 300 mm ones.



  • @wilriker No didn't change the lead screw. but once i got stuff working. I did a re-calibration of all axis's.
    Need a bit more fine tuning but 20 mm print was 20.23mm so cant complain lol.

    @JoergS5 eventually I will be using one stepper, doing that. Yeah i didn't know about the spindles being off but that does make sense. I will take that into account and grab a long spindle to cut in half, well that's if i don't come across anything else to use for the z axis. (hyper-cube set up)


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.