Allow movement without homing



  • How do I allow movement of the printhead (via paneldue) without requiring homing first?



  • I don't have a panel due, but I imagine you could execute a macro that has M564 H0. this allows movement before homing.



  • As mentioned check out M564 but be aware that the homing parameter has no effect on a delta printer.

    Frederick



  • Well I typed M564 H0, but it is not letting me lower the extruder past G1 Z0.



  • @jml said in Allow movement without homing:

    Well I typed M564 H0, but it is not letting me lower the extruder past G1 Z0.

    M564 takes two parameters.

    The H parameter determines if movement is allowed on axes that have not been homed

    The S parameter determines if movement is allowed outside the min/max values for an axis.

    Frederick



  • Oops yeah I had it fix my first problem which is the problem I mentioned above. Then I had a second problem which M564 also solved and thought just H0 would work - and when it didn't I also thought I had originally asked about both problems but I didn't!



  • Its all good now



  • @jml said in Allow movement without homing:

    Its all good now

    Glad to hear it is working for you.

    Frederick


  • administrators

    To allow movement below Z0 you can also adjust the M208 S1 command, e.g. M208 S1 Z-1 will allow movement down to Z=-1. You should only use M564 S0 if you want no limits at all on any axes.



  • @dc42 I see, good point.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.