Your Duet rejected the HTTP request: page not found

  • I am very new to 3d printers, but I have put a lot of time in learning as much as possible in a short time. I bought the Duet WiFi and first thing hooked it up to my Mac and and followed the directions for connecting found here:

    Everything went okay and I was able to get into http://duettist.local at the end and make sure things were set up to connect in future. I then unplugged it and a couple of days later went through installation as shown here :

    Once it was hooked up, I was unable to connect remotely, so I unplugged the printer and connected via usb and went through the exact same process I had the last time. However, no matter what I do this time, I get the title message (Your Duet rejected the HTTP request: page not found) when I try to connect using the IP address returned. The page just times out when I try to connect through http://duettest.local.

    I have also tried connecting through a pc with the same result and downloading and rewriting my sd card with the correct files as well as trying an additional sd card just in case. Nothing has resolved the issue. The blue light is on indicating it is connected and my router shows that it is connected. M21 returns "SDHC card mounted in slot 0, capacity 8.05Gb". M503 returns "Configuration file not found". I am reaching the end of my abilities and am hoping someone can help me get further in fixing this issue. Thanks in advance for any help you can offer.

  • administrators

    Message "Your Duet rejected the HTTP request: page not found" usually means that the web server couldn't read the web/reprap.htm file from the SD card. M503 returning "Configuration file not found" means it couldn't read /sys/config.g. So either those files are not on the SD card, or the SD card is faulty, or there is a problem with the SD card socket or the hardware interface to it.

    If you are sure (check using your PC) that the SD card does contain /web/reprap.htm and /sys/config.g, then that suggests a hardware fault, and you should ask for your Duet to be replaced.

    Note: if the SD card is removed and re-inserted into the Duet while it is powered up, you need to send M21 to the Duet to re-mount it.

  • Thanks for the info! After trying a few other things I finally got hooked up to the web server. So I have a few thoughts for anyone else that might run into this problem and maybe someone can help narrow this down with what’s possible.

    1. I believe there was a mismatch between the web server on my card and my duet firmware. Once I figured out which firmware I had and downloaded and unzipped the correct web server edition I was able to connect. I don’t know where the mismatch originated, because it worked the first time, but it’s working now.

    2. After I went through the connection process the first time, I used the reprap firmware configuration tool and took out the sd card and replaced the config.g file on the card. Something about that file was wrong. When I reverted to the original file, it started reading and after going through the configuration tool again and uploading through the web portal it worked fine. The sd card image files online didn’t help me, but I’m sure they are worth a try if you didn’t backup all your files prior to making changes.

  • Hi guys. I hooked up with these posts because one encountered a similar problem.
    First installation of a new DuetWifi.
    I follow the instructions in the guide:
    when I get to step 9, connect the duet to DWC, the link does not work and with the IP in chrome it tells me: your duet rejected the http request page not found.
    I would like to specify that in the guide there is no writing to insert any SD card and there is no written to download any files on the SD card.
    So not to do this procedure I did not use SD card.
    How could I solve the problem of access to DWC?
    if I have to download some files to insert in the SD card you can tell me where to find them?
    thank you

  • Where did you buy your Duet Wifi? It should have come with a SD card preinstalled.

  • I took it in an online market ... the guy had assured me that there were all the components and he had never used it because he was in trouble. it is not as he said. =(
    however I found the SD files on github and it works everything as it should.
    I managed to get into DWC.
    Thank you

Log in to reply