Fan 0 and Fan 1 act strangely coupled



  • I'm just setting up my simple single hotend printer with a Duet Ethernet.
    Firmware Version: 2.0(RTOS) (2018-06-05b3)
    Web Interface Version: 1.21.1

    Fan 0 is parts cooling
    Fan 1 is hotend cooling and should be temperature controlled
    Fan 2 none

    Setup is:
    ...
    ; Fans
    M106 P0 S0 I0 F500 H-1
    M106 P1 S1 I0 F500 H1 T45
    M106 P2 S0 I0 F500 H-1
    ; Tools
    M563 P0 D0 H1
    ...
    0_1536593135799_config.g

    Machine Control shows Tool Fan, Fan 0 and Fan 2, which is expected.

    Problem:
    When I move one of the "Tool Fan" or "Fan 0" sliders, the other slider always follows, showing the same percentage.
    Fan 0 is running on choosen speed regardless of the slider used. Fan 1 (Tool Fan) stays stopped.



  • That is normal. Think of Tool fan as a slider that controls the fan attached to the currently selected tool. If you had multiple tools and multiple fans it makes more sense. In your case, it's just controlling your one part cooling fan. Then it also has sliders for each individual fan below that. Make sense?



  • If you want, you can also rename Fan0 and Fan1 etc by adding a C parameter

    M106 P0 S0 H-1 C"Part Cooling"   ; Set fan 0 (Part cooling blower) G-code controlled. Thermostatic control is turned off
    
    M106 P1 S1 H1 T45 C"Hotend Fan"   ; Set fan 1 (Hotend fan) Thermostatic control. Turns on when hotend reaches 45c
    


  • @phaedrux
    Thank you for the quick response.

    With that information, I understand the concept as follows:

    • not only the hotend fan 1, but also the part cooling fan 0 is assigned to tool 0.
    • tool 0 fan slider is controlling assigned part cooling fan(s).
    • Hotend fan 1 is controlled by temperature and therefore does not show on GUI.

    Right so far?

    Which setting assigns the part cooling fan 0 to the tool 0?


  • administrators

    @peter_o said in Fan 0 and Fan 1 act strangely coupled:

    Which setting assigns the part cooling fan 0 to the tool 0?

    The F parameter in the M563 command. The default is that the print cooling fan is fan 0.



  • Ah, thanks a lot again, @dc42, @Phaedrux

    Meanwhile my printer is running the first prints with the Duet and I'm quite impressed with the print results.

    Thanks for providing this great solution!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.