[Solved] Constant vertical lines | [not solved] Uneven extrusion



  • My guess is that the lines are coming from running the heated bed in bang-bang mode with your low current motors. Try doing a PID auto-tune on the bed and and it should improve.



  • @ayudtee except that the lines are going against the layer lines.



  • @ayudtee om using a 220V heater for the bed, but if i had horizontal waves i would Guess that was My issue. Tho i think that My issue may be the too low current drivers. Thank you for suggesting to change from bangbang 🙂



  • @phaedrux, @williamwestonn My first reaction to seeing the example photos was that it was a mechanical problem. However, since only the electronics were replaced It seems unlikely that a new mechanical problem was accidentally introduced. So the problem must be with the current settings. Running bed auto-tune and implementing PID is easy, and I offered this as a suggestion because it was something that I would try if this was happening to me. It is a more precise way to control temperature so I still recommend it.

    I have Delta that is using microstepping interpolation, and also have an Ormerod 2 cartesian that has microstepping interpolation turned OFF. Here is a thread about why this is recommended:
    https://forum.duet3d.com/topic/79/microstep-interpolation/11



  • @ayudtee Thank you, and i think you were right!

    I tried up the voltage to 900mV even tho the motors has a max A1.004.
    The lines are much less noticeble but the motors are getting warmer now. Im thinking of using my 1.7A 0.9deg steppers on my X/Y axis instead of the Z axis. And i hope this will give me even better accuracy.

    My "Z-wobble" Is still there even tho i replace my bent leadscrew tho.
    If im printing in vase-mode, the surface will turn out great. So i wonder how i can remove it..
    Ill try to use PID on the bed and see what that does. But is there anything els that can cause The Z-wobble??



  • @ayudtee Is it just to do a Autopid and add the M307 H0 to activate PID and disable BangBang?

    Im also wondering how and where the settings for the thermal runaway protection is?



  • @williamwestonn Yes you will need to add an M307 command for the H0 after running the autotune. Instructions are here:
    https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control

    Duet's safety temperature monitoring is explained here:
    https://duet3d.dozuki.com/Wiki/Spurious_heater_faults_and_how_to_avoid_them

    Did you change your M350 command to disable microstepping interpolation?



  • @ayudtee No, the interpolation is still there.

    I havent tried enabling Pid for my bed yet but im afraid this isnt actually a temp issue. This may be a extrusion issue that i have no idea how to solve..

    At the start of every outer perimiter there is a tiny blob. After this there is like a tiny underextrusion followed by a slowly regaining pressure in the nozzle.. This may explain the ineven surface..



  • When you get that behavior does it look like the X-Carriage does a split second stutterbefore resuming smooth motion? That's what mine does, and I get a repeating pattern the entirety of the print.



  • I noticed today that my vertical lines are still there but im replacing the motors today to see if that does the trick..

    I just disabled retraction and enabled PID on my bed and the print looks almost perfect..

    My friend had a titan extruder and told me to use higher retraction and retract att about 70mm/s instead of 30.

    My issue with his settings is that i now noticed the motor skipping/slipping during re-extrusion in the retraction cycle.

    I cant find any recommended settings or why this happens. But my steps/mm is 819.. for what i know this is high, but people are getting good results with the titan so why wouldnt i..

    Ill post results after the next test



  • [SOLVED]

    Vertical lines were made from the motors not being the recommended voltage of what the TMC2660 drives. The minimum maxmotorcurrent is 1.2A. This you can see on the back of your motor. ex;(1004AC = 1.004A)
    Replaced my 1.8deg 1A motors with 1.7A 0.9deg motors and there is ny lines anymore.

    For what iv found my "Zwobble is some kind of extrusion issue..
    Replaced some Ballbearings in my Titan extruder and changed the Acceleration from 10000 to 500. Upped my extrusion speed and its now much better. Im still experiencing some kind of over or underextrusion after a layerchange. But ill test using "force retraction between layers, and see what that does.
    Any suggestions?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.