X and Y moving on Homez after centering Maestro?



  • ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Wed Sep 19 2018 19:43:59 GMT-0230 (Newfoundland Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X30 Y30 F6000 ; go to first probe point
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    As you can see this is stock Homez.g from RRF Configuration Tool. I am using a Orion Piezo with no luck so far BUT when the Z-bed is moving up the X and Y are also moving slowly to the back and to the left. The only other mod to the firmware is to the Config.g under Z-probe.

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P8 I1 H2 R0.5 F300 T6000 ; Set Z probe type to switch and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X30:265 Y30:265 S20 ; Define mesh grid



  • @cabal2000
    OK. I just tried I new install of the configurator but without but No z-stop and that worked, strange!! If I select Switch the x,y moves on Homez!!


  • administrators

    Do you have axis skew compensation enabled, with a M556 command in config.g?



  • @dc42
    I double checked the config file and also the Configurator page ( i have to keep it up because I am getting a Finish error if I try to save from uploaded json file) and its not enabled. Unless it is loaded on default when you select "switch" in z-probe. FYI, I did update to 2.02 last night with same results.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.