DuetWifi Delta calibration and mesh issues



  • Hi,

    My duet wifi will only calibrate up to 0.108 accuracy and if I then look at M665 values, arm length is way off showing 223 whereas the actual length is 215.

    I have a kossel mini with linear guides and ir sensor in the effector.

    Also my mesh leveling is erratic at best, but is very accurate if I run the mesh leveling with same settings twice.

    I really have no idea what I'm doing wrong anymore.. Delta's geometric values are within tolerances. Anyone familiar with these weird results and able to help?

    0_1537488832320_Map1.png 0_1537488873238_Map2.png



  • .ENOYNA ..PMUB


  • administrators

    It would be easier to diagnose the problem if you can post a height map produced using a finer grid.





  • Hope this helps. As you can see the heightmap is not very secure. Problem is that if I rerun it show about the same results.



  • Calibration results:

    Calibrated 6 factors using 10 points, deviation before 0.091 after 0.080



  • [0_1537778406100_heightmap.csv](Uploading 100%)





  • does this help?

    drives me nuts, i am trying everything but at the brink of just giving up, don't know what else i can do


  • administrators

    Please upload your height maps exactly as they come downloaded from the Duet, not re-exported from Excel.



  • @dc42 said in DuetWifi Delta calibration and mesh issues:

    load your height maps exactly as they come downloaded from the Duet, not re-exported from Excel.

    Okay, over the weekend I took the whole thing apart and rebuilt the printer using as low tolerances as possible (replaced on linear rail, added extra supports in the corners etc..). I'm running a separate cable to the IR sensor to remove any potential static. Attached the resulting height map on a surface that is not entirely flat, but not as bad as the height map shows. I'll also attach the height map ran on a glas surface.
    Settings used for this heightmap:
    ; Z-Probe
    M558 P1 H8 A2 F200 T2000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y0 Z-1.73 ; Set Z probe trigger value, offset and trigger height
    M557 R75 S10 ; Define mesh grid

    bed.g:
    M561 ; clear any bed transform, otherwise homing may be at the wrong height
    G31 X0 Y0 ; don't want any probe offset for this
    G28 ; home the printer
    G30 P0 X-73.6 Y-42.5 Z-99999 ; X tower
    G30 P1 X0 Y-75 Z-99999 ; between X and Y towers
    G30 P2 X73.6 Y-42.5 Z-99999 ; Y tower
    G30 P3 X73.6 Y20 Z-99999 ; between Y and Z towers
    G30 P4 X0 Y75 Z-99999 ; Z tower
    G30 P5 X-73.6 Y20 Z-99999 ; between Z and X towers
    G30 P6 X-36.8 Y-21.25 Z-99999 ; half way to X tower
    G30 P7 X36.8 Y-21.25 Z-99999 ; half way to Y tower
    G30 P8 X0 Y42.5 Z-99999 ; half way to Z tower
    G30 P9 X0 Y0 Z-99999 S6 ; centre, and auto-calibrate 6 factors

    0_1538381259384_heightmap.csv



  • 0_1538383946241_heightmap_glass.csv

    This was run with following settings:

    ; Z-Probe
    M558 P1 H20 A1 F200 T2000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y0 Z-1.73 ; Set Z probe trigger value, offset and trigger height
    M557 R75 S10 ; Define mesh grid


  • administrators

    What was the surface you used when you generated the first height map? It looks to me like the IR sensor gives very poor results with that surface.

    The glass one is much better, but the IR sensor is still giving less than ideal results. What was below the glass, and was there any coating on the glass?



  • Hi, I was using aluminium printbed coated with black spray paint on the first heightmap. On the second run I put a borosilicate glass surface on top of the painted surface without any coating.



  • I have tried on easy peelzy but getting similar results as the first heightmap.

    I just replaced my IR sensor this weekend, but does not show any changes in results.



  • i think i solved it...

    any black surface makes the ir sensor useless. i purchased white buildtak and all my problems are gone.

    i tried:

    black spraypaint
    easy peelzy
    black buildtak
    black pei
    all the above with glass

    nothing worked

    regards and thanks


  • administrators

    Can you confirm that the IR sensor you are using is the differential Mini IR sensor, that I sell through Escher3d.com and is also dole by duet3d.com and their distributors? It should work with black surfaces, unless you have a very old sensor. I have recently tested it with black PrintBite.



  • The ir sensor is the one sold on 1233d.nl. This one does not seem to be the same one sold on duet3d.com (picture looks different). I've ordered the one from duet3d and hope that one will work better, as even on the white PEI sheet, the results fluctuate.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.