Pressure advance causes short-to-ground on driver 3

  • Yes, I'm sure there isn't a physical short.

    The error appears whenever M572 D0 S0.1 is sent through web control, slicer, or config.g, and never appears otherwise. With pressure advance on, the extruder motor does not move at all through slicer gcode or web control, but other functions appear unimpeded.

    I replaced all config files with a fresh set made from RepRap Configurator last night, and it's having the exact same issue. Really don't know what could be going wrong at this point.

    The start g-code on my slicer (PE Slic3r) only has a home all and lift nozzle command, and my current config.g is listed below:

    ; Configuration file for Duet Maestro (firmware version 1.21)
    ; executed by the firmware on start-up
    ; generated by RepRapFirmware Configuration Tool on Wed Sep 26 2018 02:00:02 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare

    ; Network
    M550 PEnder 3 ; Set machine name
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M92 X80 Y80 Z400 E93 ; Set steps per mm
    M566 X600 Y600 Z24 E300 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z600 E1500 ; Set maximum speeds (mm/min)
    M201 X2000 Y2000 Z250 E5000 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X230 Y240 Z250 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:215 Y15:225 S20 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B3950 C0 R2200 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B3950 C0 R2200 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S1 I0 F500 H1 T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool

  • @lyze I'm not sure but I have a feeling that I read something about this happening with a certain version of DWC (due web control). Might be worth upgrading to the latest version of that. Also, are you using the latest firmware version?

  • You should update the firmware, this is something that happens with the maestro in StealthChop mode, the latest FW implements a hybrid approach, switching to spreadcycle at higher speeds.

    Alternatively if you need stealthchop in your extruder you could try following the recommendations here.
    It happened to me once operating only in stealthChop in the extruder also, will see if the recommendations are enough to avoid this ever happening again.

  • administrators

    As @genghisnico13 says, please update the firmware (to version 2.02RC2). In older firmwares, false short-to-ground indications are commonplace when using stealthchop mode at high speeds.

Log in to reply