Duet Ethernet web control suddenly stopped connecting



  • I've been using My Duet Ethernet successfully for around a year now.
    Last night, mid print, I could no longer connect to it over the Duet Web Control (my normal means of interface), which was how I started the print (like normal). But I have the LCD, and everything finished fine including a filament swap.

    Today, after rebooting my PC, router, and my Duet, I still can't connect. I have it assigned to a static IP via my router, and by going into my router settings, it clearly says that 'Duet Ethernet' is connected on the expected port. But when I go to that address in Chrome I get a:
    "
    This site can’t be reached
    10.0.0.254 refused to connect.
    "
    Also, the little 'blue drop' icon for it, that normally I see in my shortcut bar is missing.

    Any idea what has gone wrong and how I can address this? I recently upgraded it to 2.0x, and it's done probably 60 hours of printing until this happened.



  • I've tried pinging it, seems to be responding?

    C:\Users\Blah>ping 10.0.0.254

    Pinging 10.0.0.254 with 32 bytes of data:
    Reply from 10.0.0.254: bytes=32 time<1ms TTL=128
    Reply from 10.0.0.254: bytes=32 time<1ms TTL=128
    Reply from 10.0.0.254: bytes=32 time<1ms TTL=128
    Reply from 10.0.0.254: bytes=32 time<1ms TTL=128

    Ping statistics for 10.0.0.254:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms


  • administrators

    Are you quite certain that it is the Duet that is responding to the ping and not something else? You could have an IP address conflict. Test the ping again, then disconnect the Duet's Ethernet cable and test it again.



  • Thanks David. I work in tech, and sometimes it's amazing what simply waiting a day will do when the build is broken...

    Fired everything up this AM with no changes and now, it's responding as expected. No changes other than simply turning everything off/wait 12 hours/ on.
    According to my router's control panel yesterday, when inspecting all connected devices, there was only one with that IP (it's the only static ip i have, other than my Octopi that's not on), and nothing else's adderss was even close to that range. And not that it couldn't happen, but I've never had a IP conflict like that in the past.

    So, I'm glad it's working! Just wish I knew what caused this...

    One thought: Is it possible it is in some way password related? I have a password on it. When starting it this AM, as usual it asked for the password, which I had auto-fill from my Chrome's memory, and it said password was incorrect. Reloaded the page with F5, entered the same password again, and it let me in. Just a thought to troubleshoot...

    Thanks for your thoughts David



  • I'm having a very similar issue with the Maestro running 2.01. It pings and telnet works, but http is intermittent. Some times it works on power-on and sometimes it doesn't.
    M122 reports that http is enabled and doesn't seem to report anything unusual.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.