Panel due keeps saying "Connecting" but doesn't



  • I have just installed a Duet WiFi in my FolgerTech FT-5 and now it just say's "Connecting" all the time and will do nothing else. I had configured the board on the bench prior to installation and everything was functioning properly. In addition, I have also attempted to reconnect to the board via the USB interface and it is not being recognized. This is very frustrating as I bought this board in July and just finished installing it for the first time and now it is not working.

    I have checked on the Duet WiFi/Eth + Duex2/5 facebook group and found one other person who had a similiar problem and indicated that he was told the the board was bad. Can anyuone provide any insight it this problem and what I need to do to get this resolved?


  • administrators

    PanelDue only presents a USB device when the firmware has been erased and it needs to be programmed.

    The usual reasons for failing to connect are:

    1. Faulty cable. In particular, if you are using the 4-way cable then a bad crimp connection in the Din or Dout wire will cause that symptom. Faulty ribbon cables are less likely but still possible.

    2. Mismatched baud rates. The Duet defaults to 57600 baud unless you change it in a M575 command in config.g. The PanelDue also defaults to 57600 baud, but it can be changed in the Setup page. So check that there is on M575 in config.g (or if there is, it specifies B57600), and check that the PanelDue is still set to 57600.

    If you connect a PC running YAT or Pronterface etc. to the Duet via USB, you can tell whether the Duet is receiving data from the PanelDue. Send M111 S1 P3 to the Duet and it will report all received GCodes on the PC. the ones from PanelDue start with AUX: and are mostly M408 commands.

    HTH David


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.