DuetRFF Cura plugin not working on 3.5



  • Similar to this post. Re: DuetRFF Cura plugin - not working/recognizing in cura?

    I just installed Cura 3.5 and downloaded the DuetRFF plugin to use with it. The plugin shows as installed in the installed plugins list, but it is not showing up on the extensions tab. These are the two errors in the error log that seem relevant.

    2018-10-05 07:41:30,502 - WARNING - [MainThread] UM.PluginRegistry.loadPlugin [401]: Plugin Cura-DuetRRFPlugin-master uses an incompatible API version, ignoring
    2018-10-05 07:42:16,007 - INFO - [MainThread] Toolbox.src.Toolbox._updateInstalledModels [298]: Found a plugin that was installed with the old plugin browser: Cura-DuetRRFPlugin-master
    2018-10-05 07:42:17,967 - INFO - [MainThread] Toolbox.src.Toolbox.canUpdate [489]: Could not find package [Cura-DuetRRFPlugin-master] as installed in the package manager, fall back to check the old plugins

    I tried the plugin in Cura 3.4 and it showed up as expected. Thanks.



  • Perhaps @resam the plugin author can chime in.

    Or perhaps you can log an issue here: https://github.com/Kriechi/Cura-DuetRRFPlugin/releases

    3.5 has only just released.



  • I just published v0.0.19 - I would appreciate feedback.
    https://github.com/Kriechi/Cura-DuetRRFPlugin/releases

    I'm also trying to push the plugin into the new Cura Toolbox - stay tuned for that!



  • Thanks for the quick response. I downloaded V19 and now the plugin shows up in the extensions list. I added my printer, but when I tried to print a file nothing happened, but these lines showed up in the log.

    2018-10-05 21:57:13,102 - ERROR - [MainThread] UM.Logger.logException [84]: Exception: Unable to write to file leaf_cookie_cutter: name 'dialog' is not defined
    2018-10-05 21:57:13,106 - ERROR - [MainThread] UM.Logger.logException [88]: Traceback (most recent call last):
    2018-10-05 21:57:13,111 - ERROR - [MainThread] UM.Logger.logException [88]: File "X:\3.5\build\inst\lib\python3.5\site-packages\UM\Qt\Bindings\OutputDeviceManagerProxy.py", line 126, in _writeToDevice
    2018-10-05 21:57:13,115 - ERROR - [MainThread] UM.Logger.logException [88]: File "C:\Users\Spencer\AppData\Roaming\cura\3.5\plugins\Cura-DuetRRFPlugin\DuetRRFOutputDevice.py", line 126, in requestWrite
    2018-10-05 21:57:13,119 - ERROR - [MainThread] UM.Logger.logException [88]: if dialog is None:
    2018-10-05 21:57:13,123 - ERROR - [MainThread] UM.Logger.logException [88]: NameError: name 'dialog' is not defined

    I also tried it in Cura 3.4.0 to make sure that what I entered for my printer was correct and it worked fine.



  • Thanks for reporting this @changopiano! Please try v0.0.20.



  • V20 worked great! It sent the print, and I didn't see any errors in the log. I also tried the upload and simulate options and didn't have problems with any of them. Thanks.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.