IR probe and Duet Maestro



  • Hi, I've recently upgraded my Duet 0.8.5 to the Duet Maestro and while wiring my IR probe (the same one I had used before) I noticed it only blinks twice instead of four times at power up. It does seem to work - homes correctly and outputs a height map, don't know if the readings are correct though.

    What am I missing?

    Using RRF 2.01 and AUS3D v1.4 Z probe.

    I've checked the wiring: analog output<->z probe in, vcc<->3.3v, gnd<->gnd.

    Thanks!


  • administrators

    What probe type do you have selected in your M558 command in config.g?



  • This is my M558 command in config.g:

    M558 P1 H5 F120 T6000

    And my full config.g:

    ; Configuration file for Duet Maestro (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    ; Automatic saving after power loss is not enabled
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X210 Y205 Z195 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P1 H5 F120 T6000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y19.22 Z2.850 ; Set Z probe trigger value, offset and trigger height
    M557 X10:210 Y20:200 S20 ; Define mesh grid

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; set 16x microstepping with interpolation
    M92 X80 Y80 Z400 E831 ; Set steps per mm
    M566 X1200 Y1200 Z60 E300 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z600 E3600 ; Set maximum speeds (mm/min)
    M201 X3000 Y3000 Z50 E1000 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E1300 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    M671 X110:15:205 Y15:195:195 P0.5

    ; Heaters
    M305 P0 T100000 B3950 C0 R2200 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M307 H0 A131.4 C339.7 D1.0 B0 ; Set PID parameters for heater 0 (bed) at 60C
    M305 P1 T100000 B4725 C7.060000e-8 R2200 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M307 H1 A361.8 C225.6 D5.8 B0 ; Set PID parameters for heater 1 (hotend) at 210C

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool


  • administrators

    That config looks ok to me. I have one of our own IR sensors in my Maestro-powered Ormerod printer. I am fairly sure it flashes four times at power up, but I'll check next time I use it.


  • administrators

    I have confirmed, an IR sensor connected correctly to the Duet Maestro in my Ormerod printer flashes 4 times at startup, using P1 in the M558 command.



  • Thanks, but would it be a problem for my printer? The two flashes mean digital output, but I'm using the analog output anyway, am I right?
    If it's a problem, what else should I look into?


  • administrators

    Something isn't right, however the probe will still work even if the Duet is configured for analog mode and the IR sensor is producing a digital output. You won't get the benefit of the probing move slowing down when the probe gets close to trigger height.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.