A few questions regarding switching to Duet



  • If you're wired up the way its shown in that diagram you've got the wrong heater pin unbound. You've got 8 instead of 7 in M307.

    Heater pin 3 is also commonly used. Either way, check your config-override.g to see if there is a heater binding being applied after you've removed it.



  • You'll also have to modify your homeall and home z files to use G30 instead of G1 S1 Z-200



  • Thanks for all the help so far Phaedrux

    I have no idea where the config-override.g file is.I checked in the settings / system editor where all of the other folders are but it isn't there.

    I would like to ask if I am using G30 to replace the entire line G1 S1 Z-200 or just replacing the G1 line with G30 S1 Z-200.

    I am guessing the way I am setting it up now with your guidance is to use both the Zmin endstop and BlTouch?



  • @siblues You may not have one. It'll only be created if you've used M500 to save a parameter. Similar to how older firmwares use EEprom saving. M501 is used in config.g to load it.

    G30 will replace the entire G1 line. It tells the firmware to find z min with the probe.



  • Phaedrux after I changed things around how you pointed out how do I go about checking to see if the probe is actually working as it should?

    I tried
    M280 P7 S10 I1
    M280 P7 S90 I1

    The BlTouch is going through the self test at startup and then gives a constant on led.



  • What happens when you send those command? Does the pin deploy and retract?



  • No it doesn't move I even tried both codes without the l1 just to check.



  • I hope I didn't destroy this board but it was working fine and after adjusting a few things in the config now the only thing I can get the board to do is heat the bed.I get this error message whenever I try to move any of the axis

    M120
    G91
    G1X-1 F6000
    M121

    G0/G1 insufficient axes homes
    error pop



  • Add a S2 to the end of the G1 gcode line. You can't move an axis before homing.



  • Please excuse my very limited know how on the subject but what I posted was the error message that popped up where would I need to add that S2?What folder because I looked and I don't see that anywhere?



  • @siblues change the G1 line to G1 S2 X-1 F6000 or put a M564 H0 in config.g

    https://duet3d.dozuki.com/Wiki/Gcode#Section_G0_G1_Move
    Scroll down to the G0/G1 S and H parameter table.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M564_Limit_axes



  • @stephen6309 thanks for helping out I really appreciate it.I think adding M564 H0 would be best or simpler for me but where in the config.g should I add that line?



  • @siblues It can go anywhere you like. Maybe add it near your axis minima and maxima to keep it together.



  • @phaedrux Ok thanks I have almost everything ironed out but the BlTouch whenever I try to home the z axis it tells me that the probe is already triggered at start and states a
    G28 Z

    The BlTouch shows a reading of 1000 on the DWC.I figured I would mention that just in case that information is relevant to helping me solve my issues.



  • Does that mean you have the BLTouch responding to deploy and retract commands now?

    Probe triggered at start of move may mean your white wire isn't connected properly. Check the crimps.



  • Ok so let me ask a few questions first if the wire isn't connected or the crimp on the terminal is bad after issuing the probe commands would the dwc give an error message?I have tried a few of the commands for the BlTouch and they all seem to be accepted by the Duet and show up as green commands in the g-code console.The probe goes through the self test and the led is constantly on and the DWC reads 1000 for the probe.I mentioned that when I home the Z axis I get the triggered from start error for the probe.I can post the files again if you need them.



  • @siblues sure post your files again as they are now.

    I don't think there is a specific error message if something isn't connected right other than maybe the error you're getting now since it thinks the probe is already trigger before you've actually probed.

    It's still not clear if the probe is responding to the deploy and retract commands. What happens if you send M401 and M402? Does the pin deploy/retract?

    Try adding the servo commands to clear errors and retract the probe pin to the start of your homeall and homez.



  • I am going to make a new thread specifically for the BlTouch problem.I would love to hear your input in there.


Log in to reply