Strange startup



  • Hi peeps,

    I'm looking for a little advice,...When i first powdr up my duet, it says "disconnected" on panelduet and nothing will home...if i set the bed temp to >55 degrees, the message changes to "idle" and i can home the machine.

    it's really annoying to have to enter a temperature every time i restart the machine.

    any ideas?...

    Many thanks.


  • administrators

    1. Which firmware version are you running on the Duet?

    2. What does the temperature read in Duet Web Control before you set it to 55C?

    3. If you send command M408 S1 to the printer from either USB or DWC before you set the temperature to 55C, what is the response?



  • hi, thanks for the speedy response (as always i might add)

    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.01(RTOS) ELECTRONICS: Duet Ethernet 1.02 or later FIRMWARE_DATE: 2018-07-26b2

    Both temps read actual values and update if you blow on them

    M408
    {"status":"O","heaters":[42.6,36.6],"active":[0.0,55.0],"standby":[0.0,55.0],"hstat":[0,0],"pos":[0.000,0.000,0.000],"machine":[0.000,0.000,0.000],"sfactor":100.00,"efactor":[100.00],"babystep":0.000,"tool":-1,"probe":"1000","fanPercent":[30.0,100.0,100.0,0.0,0.0,0.0,0.0,0.0,0.0],"fanRPM":0,"homed":[0,0,0],"msgBox.mode":-1}

    Hope this helps

    Thank you for your attention


  • administrators

    I think the reason is that your printer has no VIN power applied and the version of PanelDue firmware you are using doesn't understand the "O" status code. Try updating the PanelDue firmware.



  • hi, thank you for your continued support.

    paneldue has latest firmware, with logo...

    it's not just the pandue, the board must be powered as i get temperature feed back etc on webb control, if i call for home all from webb app, nothing moves, webb app says "disconnected" if i change bed temp to 55 it says"idle" and i can now home things..

    very odd..........



  • ill shoot a quick video if it helps


  • administrators

    Please confirm the version of firmware on your PanelDue.



  • hi,

    firmware is PanelDue-5.0i-7.0i

    but i seam to remeber it doing similar before i updated it...

    thsnks


  • administrators

    Go to the Setup page of PanelDue, and there you will find the firmware version displayed.



  • Sorry!...

    it's 1.21.3(13b1)

    my bad.
    thanks again for your help...



  • Hi guys,

    As a work around i've set the bed to 55 degrees in the last line of config.g.

    looks like it's working.

    I don't think i've done anything wrong with my config?..apart from lack of comments....

    ; General preferences

    M555 P5 ; Set firmware compatibility to look like Repetier
    M667 S1 ; Select CoreXY mode
    M552 S1 ; Enable network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet
    M575 P1 B57600 S1 ; Comms parameters for PanelDue
    M111 S0 ; Debug off

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X100 Y100 Z1520 E143 ; Set steps per mm
    M566 X500 Y500 Z40 E100 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000 Y30000 Z1500 E20000 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z500 E1000 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E500 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X340 Y220 Z267 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z2 S1 ; Set active high endstops
    m558 p4

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S140 ; Set temperature limit for heater 0 to 140C
    M305 P1 T100000 B4725 C7.06e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S350 ; Set temperature limit for heater 1 to 350C

    ;M301 H1 P10 I0.10 D100 T0.50 S1.0 ; PID settings for extruder 0
    ;M301 H2 P10 I0.10 D100 T0.50 S1.0 ; PID settings for extruder 1

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 ; Define tool 1
    G10 P0 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P0 R55 S55 ; Set initial tool 0 active and standby temperatures to 0C

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    T0
    M572 D0 S0.03

    M140 S55

    Once again many thanks for a great product.


  • administrators

    @dorro1971 said in Strange startup:

    As a work around i've set the bed to 55 degrees in the last line of config.g.

    Does that really solve the problem?

    The M408 response that you posted:

    M408
    {"status":"O","heaters":[42.6,36.6],"active":[0.0,55.0],"standby":[0.0,55.0],"hstat":[0,0],"pos":[0.000,0.000,0.000],"machine":[0.000,0.000,0.000],"sfactor":100.00,"efactor":[100.00],"babystep":0.000,"tool":-1,"probe":"1000","fanPercent":[30.0,100.0,100.0,0.0,0.0,0.0,0.0,0.0,0.0],"fanRPM":0,"homed":[0,0,0],"msgBox.mode":-1}

    was taken when your Duet had 5V power (perhaps from USB) but no VIN power - that's what status "O" means. So I assumed the problem you were getting was because you were not applying VIN power. If you still get the problem when VIN power is applied, please run M408 again when the PanelDue is failing to connect but you have VIN power applied (and without that extra line in config.g of course).



  • Duet is powered all the time from startup, no usb input.

    if i set bed temp to 55 or more it goes to idle if i then set bed temp to 0 everything still works.

    only power source is Vin 24v...(actually 27.5)..maybe a litlle high?

    and yes that solves my problem I just don't like not knowing why..

    panel duet says "disconnected" but still reports temperature changes...so it must be connected right?...it won't read memory card until i do the bed temp thingy...

    a real puzzler...

    also if i pause and canccel a print, when i restart it it homes but hangs..this may be a slicer issue but the first run is fine and if i do a second after completion it's fine...only a problem if cancelled...



  • This post is deleted!


  • when my current print is complete i'll double check......



  • Ok, initial power on..24v only, last line of config removed.

    M408
    {"status":"O","heaters":[44.0,54.9],"active":[0.0,55.0],"standby":[0.0,55.0],"hstat":[0,2],"pos":[0.000,0.000,0.000],"machine":[0.000,0.000,0.000],"sfactor":100.00,"efactor":[100.00],"babystep":0.000,"tool":0,"probe":"1000","fanPercent":[30.0,100.0,100.0,0.0,0.0,0.0,0.0,0.0,0.0],"fanRPM":0,"homed":[0,0,0],"msgBox.mode":-1}

    after m140 s55 issued

    M408
    {"status":"I","heaters":[52.2,55.0],"active":[55.0,55.0],"standby":[0.0,55.0],"hstat":[2,2],"pos":[0.000,0.000,0.000],"machine":[0.000,0.000,0.000],"sfactor":100.00,"efactor":[100.00],"babystep":0.000,"tool":0,"probe":"1000","fanPercent":[30.0,100.0,100.0,0.0,0.0,0.0,0.0,0.0,0.0],"fanRPM":0,"homed":[0,0,0],"msgBox.mode":-1}

    Checked wiring,..all good..is it worth re updating duet and panel duet?
    Any ideas...

    thank you..


  • administrators

    Before you send the M140 command, please send M122 and check the reported VIN voltage.



  • I'll do that...I wonder if the voltage is under low load. switching the bed on causes current draw and the psu to step up?

    It's printing now, I'll try that tomorrow..i'll also drop a volt test on it...

    Thank you.



  • 19:48:06
    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.01(RTOS) running on Duet Ethernet 1.02 or later
    Board ID: 08DGM-956GU-DJMSN-6J1DJ-3S86L-K9R3G
    Used output buffers: 3 of 20 (13 max)
    === RTOS ===
    Static ram: 28476
    Dynamic ram: 95932 of which 16 recycled
    Exception stack ram used: 272
    Never used ram: 6376
    Tasks: NETWORK(ready,328) HEAT(blocked,1324) MAIN(running,3564)
    Owned mutexes:
    === Platform ===
    Last reset 00:01:02 ago, cause: software
    Last software reset at 2018-10-15 19:47, reason: User, spinning module GCodes, available RAM 6140 bytes (slot 0)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 28.3, current 29.0, max 29.1
    Supply voltage: min 27.6, current 27.7, max 27.8, under voltage events: 0, over voltage events: 0
    Driver 0: ok, SG min/max not available
    Driver 1: ok, SG min/max not available
    Driver 2: ok, SG min/max not available
    Driver 3: ok, SG min/max not available
    Driver 4: ok, SG min/max not available
    Date/time: 2018-10-15 19:48:06
    Slowest loop: 6.17ms; fastest: 0.07ms
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 6.22ms; fastest: 0.03ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8
    Interface state: 5
    === Expansion ===

    still says disconnected until i issue M140 S(>55)...

    I'll uncomment the last line of config for now...

    Voltage test with meter did not show anything wrong....

    PUZZLE....



  • tried it with ethernet disconnected just in case...still no difference...


Log in to reply