Remapped driver



  • Hi, I think this topic has been talked about, but still I do not see the solution. I have burned the driver corresponding to the output of the E0 extruder, and I want to use the E1 output to solve the problem. I have tried with:
    M584 X0 Y1 Z 2 E3 and the only thing I get with this is that the hotend disappears. Right now, as I have configured the config.g I find two extruders in the Machine properties menu and there is no way to eliminate the E0. I want to eliminate E0 because if by mistake it were to work I do not know what could happen, probably more sparks and fire ... Thank you and sorry for my bad English.

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Oct 18 2018 21:09:21 GMT+0200 (CEST)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PENDER 3 ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P4 S0 ; Drive 3 goes backwards
    ;M584 X0 Y1 Z2 E4
    M350 X256 Y256 Z256 E16 I0 ; Configure microstepping without interpolation
    M92 X1280 Y1280 Z6400 E514 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X9000 Y9000 Z180 E1200 ; Set maximum speeds (mm/min)
    M201 X575 Y575 Z100 E575 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E500 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X230 Y230 Z250 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    ;M307 H4 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M307 H3 A-1 C-1 D-1
    M558 P9 H5 F120 T6000 A3 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X32 Y-2 Z0.35 ; Set Z probe trigger value, offset and trigger height
    M557 X20:200 Y20:200 S45 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    ;M563 P0 D0 H1 ; Define tool 0 cambiado para extrusor E0 pase a E1
    M563 P0 D1 H1
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    0_1540056242291_Captura de pantalla 2018-10-20 a las 19.22.14.png


  • administrators

    @danivv said in Remapped driver:

    M584 X0 Y1 Z 2 E3

    That should be:

    M584 X0 Y1 Z2 E4

    The M563 command should be exactly as it was originally:

    M563 P0 D0 H1

    because the M584 command maps extruder drive 0 to driver 4.



  • Thank you very much for your reply. I have made all the changes he suggested, but the E0 continues without disappearing ... And now the E1 does not appear.

    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Oct 18 2018 21:09:21 GMT+0200 (CEST)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PENDER 3 ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P4 S0 ; Drive 3 goes backwards
    M584 X0 Y1 Z2 E4
    M350 X256 Y256 Z256 E16 I0 ; Configure microstepping without interpolation
    M92 X1280 Y1280 Z6400 E514 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X9000 Y9000 Z180 E1200 ; Set maximum speeds (mm/min)
    M201 X575 Y575 Z100 E575 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E500 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X230 Y230 Z250 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    ;M307 H4 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M307 H3 A-1 C-1 D-1
    M558 P9 H5 F120 T6000 A3 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X32 Y-2 Z0.35 ; Set Z probe trigger value, offset and trigger height
    M557 X20:200 Y20:200 S45 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0 cambiado para extrusor E0 pase a E1
    ; M563 P0 D1 H1
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    0_1540061126317_Captura de pantalla 2018-10-20 a las 20.41.43.png


  • administrators

    That's right, it's still E0 even though you have mapped it to driver 4, which is the one whose connector is labelled E1.



  • Ahhhhh Ok!!

    Tahnks!!


  • administrators

    Out of interest, how old is your Duet, and how did you damage the E0 driver? It's rare for the drivers to fail these days.



  • Hello, my duet is a week old, connect an engine (25mm brand pancake bondtech) which did not work, it vibrated a little but it did not turn, one of the times I connected it started to heat up, until they started to jump sparks the duet (my tears also leapt), I think it was the engine's fault despite being new ... I have again asked for another similar one, I'm worried if it happens again ...
    Thank you very much for your interest.


  • administrators

    Where exactly did you see the sparks?



  • In the driver microchip

    0_1540068810573_4B992E28-B648-46C7-805C-2EC882A0DF49.jpeg


  • administrators

    Please post more photos of the failed chip, in particular one taken from directly overhead and one taken looking towards the side of the chip close to the damage. I want to check that the chip was correctly aligned with the PCB pads on that side.



  • 0_1540098236241_63978CA8-B039-4DCF-A4BF-C38B64B9B2DF.jpeg

    0_1540098249648_67EE6419-0D7C-4DED-A113-F75B86F752EB.jpeg

    0_1540098296010_580B6405-800E-4F37-BC30-BC0CD43FEF49.jpeg

    0_1540098320108_58D4718F-7E69-4C3B-B444-2080D02ABE97.jpeg

    0_1540098343816_AB891B9E-265E-4355-889D-12865249161A.jpeg


  • administrators

    The soldering looks OK, however it's very rare for stepper motors to have shorted windings. So I will give you the benefit of the doubt and approve a warranty replacement for the Duet if you wish to return it.



  • Thank you, I appreciate it very much.


  • administrators

    @danivv it might be worth checking the motor using one of the other (working) stepper channels as well as that will allow you to confirm the motor is working correctly.



  • @t3p3tony
    I thought about doing it, but the engine got very hot and smelled like burnt, and I did not dare to try it for fear of burning another channel.


  • administrators

    @danivv ahh fair enough. Sounds like you could have the current set very high for that motor however I have checked the config.g and the motor:
    https://www.bondtech.se/en/product/nema17-pancake-stepper-25mm/
    and if the motor is working correctly the 500mA should be ok, which is what you have it set to.



  • @t3p3tony
    If just that, from 0.7A, I have asked for another equal ...


  • administrators

    Do you have a multimeter? if so, you can measure the resistance of each phase. Also make sure there is no continuity between the two phases, or between either phase and the case of the motor.

    Does the motor have wires coming out of it, or does it have a 6-pin connector on it? If it has a connector, it is possible that the colours of the wires do not correspond to the usual phase colours.



  • @dc42

    Following the diagram I have attached the winding A and B. In both gives me continuity without resistance, ie short circuit. And endless resistance between them.

    0_1540131503656_F63248EF-C9D3-47DE-A17D-BF4BB65757B1.jpeg

    I can do some more test, if you want. It seems that the duet works correctly except for the E0 output.


  • administrators

    Can your multimeter measure as low as 4.2 ohms?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.