Startup problem - ground?



  • Hi,

    after some hours of printing SD card died.
    After changing SD card and printing some more hours strange thing happened.
    Looks like some hardware problems?
    Board is trying to boot up, but it is looping.
    https://youtu.be/6rEjPdk68i8
    Have changed it with board from other printer - works perfectly.
    Should I send for replacement?


  • administrators

    @alishkus can you try it with nothing plugged in and with a different SD card that has all th config on it. I wonder what caused the first SD card to fail? How long was it working for? When you say you swapped the board with another working one was that the Duet or the Duex or both?



  • Ok.
    I have unplugged everything and insert new SD card with fresh config.
    Same stuff happens (can upload video if needed)
    Some time it starts up, but its not stable. Usually restarts itself 1 hour into print...
    It was working roughly for 50-70hours of printing
    First SD failed without any intervention - just in the middle of print.
    I have swapped only Duet Wifi.


  • administrators

    @alishkus please can you run M122 after it fails but before you power cycle the printer.



  • M122
    === Diagnostics ===
    Used output buffers: 3 of 32 (9 max)
    === Platform ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 1.21 running on Duet WiFi 1.02 or later + DueX2
    Board ID: 08DGM-956GU-DJMSN-6JTDG-3SN6T-9UNMD
    Static ram used: 16152
    Dynamic ram used: 100408
    Recycled dynamic ram: 2224
    Stack ram used: 1224 current, 4528 maximum
    Never used ram: 7760
    Last reset 00:00:29 ago, cause: reset button or watchdog
    Last software reset at 1969-12-31 23:59, reason: deliberate Unknown, spinning module none, available RAM 4294967295 bytes (slot 0)
    Software reset code 0xffff HFSR 0xffffffff, CFSR 0xffffffff, ICSR 0xffffffff, BFAR 0xffffffff, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 44.4, current 45.4, max 47.0
    Supply voltage: min 12.1, current 12.2, max 12.3, under voltage events: 0, over voltage events: 0
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Driver 5: standstill, SG min/max not available
    Driver 6: standstill, SG min/max not available
    Expansion motor(s) stall indication: no
    Date/time: 2018-10-29 13:55:21
    Slowest main loop (seconds): 0.014302; fastest: 0.000052
    === Move ===
    MaxReps: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Responder states: HTTP(1) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.20
      WiFi MAC address 5c:cf:7f:76:63:ad
      WiFi Vcc 3.32, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 16552
      WiFi IP address 10.10.65.9
      WiFi signal strength -68dBm, reconnections 0, sleep mode modem
      Socket states: 2 0 0 0 0 0 0 0
      === Expansion ===
      DueX I2C errors 0


  • Is there any fast way to find a bug?
    Because this issue caused me quite some money and client problems...


  • administrators

    Please try the following:

    1. Check whether are components on the Duet are getting hot, in particular the WiFi module, the 3.3V regulator (U2) and the main processor.

    2. Update the firmware to 2.01 or 2.02RC3.

    3. With only power connected, check if the problem (looping when booting up) still occurs.

    4. If it still occurs, replace the config.g file with an empty one and see if it boots up. You will be able to tell by watching the DIAG LED, I think.

    5. If it does boot up, add M552 S1 to config.g and see if it boots up.



    1. No particular place of board is getting hot
    2. Have tried both various updates and downgrades. Strange thing I cant upload any software via webcontrol (no response)
    3. Only Duet wifi - problem still occurs
    4. Have tried blank config.g - almost thought it worked but then board started looping again

    Doesnt look like firmware for me. I would guess CPU or SD reader, but cant really test them...


  • administrators

    It does sound that your Duet may be faulty, so I suggest you ask for a replacement.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.