Error: Your Duet rejected the HTTP request: page not found



  • Hello! I'm getting the "Your Duet rejected the HTTP request: page not found" error. Previous posts led me to believe that the Duet could not locate the /www folder, which I verified via my PC was present. Sending M21 yields "SDHC card mounted in slot 0, capacity 3.96GB" I tried a known good SD card, reformatted with the github content. Still no luck. M503 returns "Configuration file not found"

    I had everything plugged in and operational for a day. I had all motors and endstops configured correctly. The device still lights up as normal, and I can interface via USB, however it cant read the config file.

    Help would be appreciated.


  • administrators

    What happens if you power up the Duet, connect via USB, and send M39 instead of M21? M39 reports the existing SD card status, whereas M21 tried to mount the card again.



  • I tried that this morning, it reports back "SD card in slot 0: capacity 3.90 GB, free space 3.90GB, speed 20.00MByte/sec, cluster size 64kb"

    Thanks again for the help


  • administrators

    That looks correct. Does the SD card definitely have a /www folder with the correct Duet Web Control files in it?



  • Yes it does - I also tried with a known good 4GB card, and loaded it with the github SD Card contents file, verified the www & sys folders and files are present, but I get the same result. I can see the config file, but M503 shows its not found...


  • administrators

    Is this a brand new genuine UK-manufactured Duet, or an older Duet that has been working but has just started to have this problem, or something else? It sounds rather like an SD card socket issue I remember that used to crop up a long time ago.



  • It's a brand new board, just purchased from Filastruder.com in the U.S. It looks like its v1.04



  • Any other suggestions? The vendor is not willing to replace my Duet under warranty until it is notated here - kinda frustrating that this is the only means of support - going on 2 days to get a resolution, who knows when I'll see a replacement if that's needed. Starting to regret this purchase...


  • administrators

    What is odd is that the SD card is showing up as working but its not reading the config file.

    I think we will have to exchange it under warranty to investigate further. Please let Filastruder know.


  • administrators

    Your M39 command reported 3.90Gb both as the capacity and the free space, which implies that there are no files on it. So please check again that you have the correct folders and files on the SD card.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.