Baby stepping not working


  • administrators

    @SupraGuy, which firmware version are you using?



  • 2.02RC3

    @supraguy said in Baby stepping not working:

    Firmware Name:	        RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics:	Duet WiFi 1.02 or later
    Firmware Version:	2.02RC3(RTOS) (2018-10-17b2)
    WiFi Server Version:	1.21
    Web Interface Version:	1.22.3
    

  • administrators

    Thanks!

    • Can you confirm that the bed compensation you are running is G29 mesh bed compensation?
    • Does baby stepping work if you just load a height map (G28 S1), or do you actually need to probe using G29?
    • If you send G29 S2 to cancel using the height map, does baby stepping stop working again?

    PS - if you are using bed.g to do the bed compensation, please post the contents of that file.



  • I do compensation in 2 ways. There is a mesh compensation (heightmap.csv) file. It does occur to me that I probably never reload it. (It's currently full of 0.000 values anyway)
    heightmap.csv

    RepRapFirmware height map file v2 generated at 2018-09-20 12:25, mean error 0.000, deviation 0.000
    xmin,xmax,ymin,ymax,radius,xspacing,yspacing,xnum,ynum
    35.00,185.00,25.00,250.00,-1.00,75.00,75.00,3,4
      0.000,  0.000,  0.000
      0.000,  0.000,  0.000
      0.000,  0.000,  0.000
      0.000,  0.000,  0.000
    

    So I do (Or plan to) use G29 for mesh leveling. I'm debugging issues with my underbed piezo sensors, now, too, so they're only currently being used for homing, and it's just now at the point where I can use those for the G32 compensation, calling the bed.g file which is used to set a base level on the 2 Z screws, which seem to like to drift a little when the machine is powered off. I do not send a G29 S2 to unload it under any circumstances that I know of.

    I will try re-loading it and see if that affects babystepping. Will again have to wait until I am home. (There's that timezone thing again.)



  • Didn't get much done last night looking at this,
    Sorry. My bed.g file is up there on a post from Oct 30.
    bed.g:

    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Jun 26 2018 20:51:43 GMT-0600 (Mountain Daylight Time)
    M561 ; clear any bed transform
    ;M558 P0 ; unset Z probe for now...
    ; Probe the bed at 3 points (Right on top of the piezo sensors for now, will change later)
    M561 ; clear any bed transform
    M201 X950 Y600 Z5 E450
    G30 P0 X15.0 Y137.5 H0 Z-99999
    G30 P1 X205.0 Y137.5 H0 Z-99999 S2
    M201 X950 Y600 Z75 E450
    

    It is running this that seems to make the babystepping work. (Just clicking the "Auto Bed Compensation" button on the DWC.) I was able to confirm that neither G28 S1 nor G29 S2 makes a difference once babystepping works. I didn't get to checking if that makes it work before running the bed compensation.


  • administrators

    Thanks for the feedback. I will look into this next week.



  • And in typical fashion, it no longer fails.

    Over the weekend, I did some physical work on the printer, though I did not touch anything for Z movement. I replaced the carriage, and the heater block and nozzle. I did change my maximum X and Y movement speeds, acceleration and jerk (Higher acceleration, lower jerk) and noted that baby stepping worked first thing when I powered it up. I thought that I might have a clue, and restored the backup of the /sys folder that I had from before any changes, and it still works. I tested using the same gcode file (20mm cube with 25 loops of skirt) It now works with or without running the automatic bed compensation. I did not change any of the home files.

    I have no explanation, which kind of bothers me.



  • Not sure if there was any solution to this. I'm seeing the same issue. Baby stepping seems to do nothing. Executing it from the PanelDue

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 2.02(RTOS) (2018-12-24b1)
    WiFi Server Version: 1.21
    Web Interface Version: 1.22.6

    I am loading the meshmap in the config.g G29 S1


  • administrators

    Baby stepping is only 0.02mm at a time, so you may need a few presses to see anything. Also it isn't quite instant, it may take u to 1 move + 2 seconds half a second before it makes a difference.

    In firmware 2.02, if the printer is idle when you send the babystepping command, movement is instant.



  • Hi,

    I have the same issue.
    0.05 per dwc and 0.02 per Hardware Buttons. Offset is displayed correct in the dwc, no bed compensation, no min Z Limit and a G92 0.2 at the end of the homing files.

    Dwc, fw and wifi are the newest Version available.

    When i home Z, i can move Z up and down. Tried +/-2mm, there is no change in the layer. Like i said, dwc shows me the babystepping offset.

    I tried to change the M290 S Parameter to Z, there was an info in the gcode section of dozuki. No luck.

    Any idea?


  • administrators

    @torro said in Baby stepping not working:

    Hi,

    I have the same issue.
    0.05 per dwc and 0.02 per Hardware Buttons. Offset is displayed correct in the dwc, no bed compensation, no min Z Limit and a G92 0.2 at the end of the homing files.

    Dwc, fw and wifi are the newest Version available.

    When i home Z, i can move Z up and down. Tried +/-2mm, there is no change in the layer. Like i said, dwc shows me the babystepping offset.

    I tried to change the M290 S Parameter to Z, there was an info in the gcode section of dozuki. No luck.

    Any idea?

    Please describe what issue you are having. People have reported different issues in this thread. Also confirm that you are running firmware 2.02 (not a beta or RC version).



  • Hi there

    Duet Web Control 2.0.0-RC3

    Electronics: Duet WiFi 1.02 or later
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.02(RTOS) (2018-12-24b1)
    Duet WiFi Server Version: 1.22

    When i increase/decrease Z per babystepping (0,05 in DWC or 0,02mm per programmed hardware buttons) the babystep offset is correctly shown in the DWC. BUT nothing happens with the first layer. i started a print and increased babystep offset to !!!2mm!!!, heighof the first layer didn´t change.



  • Hi,

    Just made a quick test.
    There is a difference visible, but i expected more. Few circles. the outer with baby stepping at 0, towards the middle, i increased per DWC in 0.1mm steps

    0_1547453118311_DSC_0358.JPG
    0_1547453124885_2019-01-14 08.54.53.jpg


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.